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ABSTRACT

Printed circuit boards (PCBs) are exceeding the limits of the classic board design.
The goal of this thesis is to inform the reader about the layout and fabrication of PCBs
from generic to high speed designs. In chapter 2, Basic Design and Layout, I provide the
generic PCB design that will give a basic understanding of board layout and fabrication
using Cadence® software tools, which will simplify understanding of the high speed
PCB design.
Cadence® provides a path to designing PCBs, but to rapidly prototype the design
we need to implement simulations. We accomplished the simulations using the Advanced
Design System (ADS) tool which is used for designing high frequency PCBs. In this
thesis the reader will see examples developed to illustrate high speed issues in digital
designs using ADS and correlated simulated and measured values.
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1. INTRODUCTION
Printed circuit boards (PCBs) are a significant part of the modem electronic
packaging found in almost every consumer electronics product. PCBs consist of both
electrical and non-electrical layers. Most simple circuit boards are made with 2 to 4
electrical layers. Some of the industrial applications require 8 to 20 layers. The designer
decides the number of layers to use. The number of layers depends on the capacity of the
board to accommodate all the surface mount devices (SMDs). Increasing the number of
layers reduces the circuit density but at the same time increases cost, complexity and
thickness of the PCB [Sharawi, 2004]. PCBs interconnect different electronic
components such as resistors, integrated circuits, capacitors, inductors and connectors
without discrete wires

[Liet al., 2004], The components are connected by printe

or traces of copper [Sharawi, 2004]. Some PCBs are double-sided with copper traces on
top and bottom layers. In such cases traces on one side of the board are connected to
traces on other sided with wire links. They can also be connected by using plated through
hole technology at the extra cost of manufacturing. After a PCB has been manufactured,
components are attached to the traces, usually by soldering. The main purpose of the PCB
is to provide mechanical support for the components and the electrical interconnection
paths, and dissipate the heat generated.
PCBs were first invented in about 1936 as part of a radio set by the Austrian
engineer Paul Eisler. In about 1943 the USA began to use PCB technology to make
mgged radios for use in World War II. PCBs were not commercialized until 1948. PCBs
have been available in commonly used consumer electronics since the mid-1950’s
[ Wikipedia, 2005].
In 1965, after the invention of integrated circuits (ICs), Intel co-founder Gordon
Moore observed that the number of transistors on a given piece of silicon doubled every
couple of years. This rapid growth and decrease in transistor size improved performance
and speed and decreased the cost of the ICs [Granberg, 2004].
Surface mount technology (SMT), in which components are placed directly on to
the surface of the PCB, has been widely used since the late 1980s [Granberg, 2004]. An
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advanced PCB design technology such as microvias, high-density interconnects (HDIs),
embedded passives and high pin-count field programmable gate arrays (FPGAs) were
mainly available to power users for designing leading-edge products for global
organizations ten years ago. These low cost design technologies advanced into market
due to their availability. This became the governing factor in determining a company’s
success Maliniak [2004],
Today’s PCBs are exceeding the limits of the classic board design. For example,
in mobile telecom interconnects board dimensions decrease rapidly with the use of fewer
but more complex components. Nowadays, PCB designers and signal integrity (SI)
engineers are provided with a variety of simulation tools to perform difficult design tasks.
Cost, speed and accuracy always govern the decision of a particular design Maliniak
[2004],
Nowadays, multigigahertz processors are being used more: 20 GHz processors are
running in labs. Boards have been designed that transmit 12.5 Gbps over a single
differential pair of copper traces, and individual devices are now transmitting data rates
up to 40 Gbps over parallel traces. To achieve all these requirements, designers are using
high-speed circuitry and mixed-technology designs, which have found applications in the
telecommunications and PC industries. A more extensive discussion of the background of
PCBs can be found in Maliniak [2004].

1.1. Generic printed circuit board design process
To design a PCB several choices must be made. The design process requires a
large amount of information, which includes board size, shape, board cost, board
assembly and maintenance. If any of these elements are overlooked a board may be
expensive or have to be redesigned. A basic design flow process is shown in Figure 1.1.
More information about the design process can be found in Robertson [2004].
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Figure 1.1
1.1.1.

Design flow process for generic PCB design

Initial requirements
The first step for a PCB design is to collect datasheets for all the components to

be used in the board. Then the designer and/or the engineer must discuss the method for
laying out the schematic and decide on the size of the board. The designer must also
determine what materials should be used for the board.
1.1.2. Library management
After selecting the components required for a board, the designer must check if all
the components are available in the library. If not, the designer must create the part
symbol and define part attributes. The designer can change the reference, the part
numbers, the geometry and the packaging of the parts. The designer should also check
whether all the parts have footprints for all the components in the board; if not, the
designer should create the footprints. The designer can create his own library and set
them up with other available libraries.
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1.1.3. Design entry
The designer creates the circuit diagram using the schematic computer aided
design (CAD) tools. The designer must do a schematic check after completion of the
circuit diagram. Then the project should be transferred to a netlist to import it into the
PCB CAD package. The packaging process will depend on the CAD package used. After
packaging the circuit design one can create the basic bill of materials (BOM).
1.1.4. Creating layout
The PCB layout created will determine the final physical form of the circuit. PCB
layout is created from the circuit diagram, by creating the board outline, and by
physically placing the components and routing the components for the best results. The
PCB layout can be routed manually or automatically. Usually, even though the designer
can route the traces using auto routing, the best results can be achieved by routing some
traces manually.

1.1.5. Simulations
Simulations provide the designer with valuable guidance to layout and routing.
Simulation can also reduce the risk of ill performance and the cost of the board.
Simulations on the PCB are performed by providing specific inputs to the circuit and
observing both the outputs and the internal operations of the circuit giving detailed
feedback as to what is happening and when.
Before beginning the simulations on the board the designer must check whether
all the components that are going to be used in the simulation have the simulation
models. Simulation is the complicated process of ensuring that under every possible set
of input conditions the circuit is behaving as desired, and giving the correct output at the
correct time. Using simulation tools the designer can verify and test the final design
before manufacturing the board by verifying the correct operation of the circuit.
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1.1.6. Creating manufacturing output
The designer must supply several files to the manufacturer of the board. These
include the bill of materials (BOM) and several design files. The BOM is a list often in
spreadsheet form, which provides the reference designator, part number, quantity,
descriptions and other information for all parts in the schematic. The board design files
required by the manufacturer are listed below:

> Gerber files must include the top mask layer, the top silkscreen layer, the bottom
mask layer, the bottom silkscreen layer, and the ASCII text component location
files. Gerber files provide the x-y locations of all objects on the board.
> An aperture list that provides the shape and the information required to render the
Gerber image, which is in text format.
> The centroid file, which is in text form, that provides the relative location of the
components (defined by references designator) on the PCB. This allows automatic
joining of references.
> Drill file, which is usually given in the form of a drawing, that indicates where to
put various size holes on the board.
> Also provide any one of the scanned image (.jpg or .bmp formats), the bare board
or the Assembly drawing.

Additional data is useful to make PCB assembly easier. Some design software
packages require special steps in order to extract usable data for the manufacturer. It is
always recommended to follow the directions given by the software package
manufacturer to extract necessary files.

1.2. High speed digital board design process
With the growing demand for smaller and high performance PCBs, designers
have begun using high frequency pulse edges i.e., when the edge rate of the data is less
than the propagation delay of the PCB traces [

2004], Because of this there are
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some physical side effects that are normally neglected, such as propagation delay,
reflections, crosstalk losses, etc. [SPECCTRAQuest™ SI Expert, 2001]. These factors
make the layout a major part of the design and not only a carrier of components and
interconnects. When the interconnections on the PCB begin to act like transmission lines
they must be handled like a distributed series of inductors, resistors and capacitors
[Sharawi, 2004],
As a high speed board design analyzes the things that are not taken into
consideration while designing generic PCB boards, good planning is needed to make an
effective PCB design. As a board becomes more and more complex for high speed PCB
design, the designer uses different CAD tools such as Cadence® Allegro®, Cadence®
SPECCTRAQuest™, Avant! Hspice, Ansoft Spicelink and high frequency structure
simulator (HFSS) [Mu, 2002]. Reasons for choosing each include:

> Cadence® Allegro® is a popular layout tool in high speed PCB design.
> Cadence® SPECCTRAQuest™ is used to simulate the PCB board and it is linked
to the Allegro® due to the use of a common database.
> Hspice tool is used to analyze the simulation data.
> HFSS provides 2D and 3D field solutions on vias, connector’s etc., especially
when high speed analysis is required.

The set of tools discussed above must be used effectively in designing high speed
PCB boards, as they play a significant role in reducing the difficulties in designing and
reducing cost. No signal simulation tool we found can provide all the requirements in
designing a high speed digital PCB board.
The problems faced in high speed PCB design that are not taken into
consideration during the generic board design are as follows [S
2004]:

> Termination schemes

et
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> Skin effect (frequency dependent attenuation)
> Dielectric losses
> Impedance discontinuities/reflections
> Inter-symbol interference
> Crosstalk
> Decoupling/bypassing in power distribution
> Board stack up
> Signal edge rating

The design flow for designing the high speed digital design is almost the same as
the design flow used for designing a generic board. It does, however, vary in some
aspects.
For example, the designer should simulate the design prior to layout to identify
design constraints that will direct the future layout. Layout files are not needed at this
stage and the schematic tool is enough to solve the signal integrity and EMC problems at
the initial stage. This pre-layout analysis is very useful as the critical nets and signals
with fast switching characteristics are identified before pre-layout analysis. According to
the requirements of the critical nets and signals, constraints are determined which will
help in routing those nets. The PCB board is laid out according to the specifications and
results from the pre-layout analysis. Post-layout analysis must also be done using layout
tools. There are some problems that can only be determined after PCB layout.
Simulations on the board are performed after design models are created during the
analysis process. Design models are then assigned to all the parts in the board. The
detailed analysis is carried out on the critical nets and signals, which contain all the
required information. If the analysis of the critical nets and signals indicate any problems
by using the simulation tools, the designer should modify the layout by rectifying those
problems and rerouting the design for reducing the SI issues. According to Lesea [2004],
some of the reasons for using the SI simulations in high speed PCB board design include:
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> The first choice of using the SI simulation is to simulate and have working results
on the first PCB rather than simulating later after having a series of failed boards.
The cost of an SI tool is much less than the cost of a manufactured board
experiencing more failures.
> A change in layout is required every time the PCB is modified by fixing
problems. A new layout or a new fabrication is required to go through the entire
assembly process. This delays the launch of the product in the highly competitive
market.
> Poor signal integrity results in jitters to all the signals in the design. Jitters are due
to crosstalk, ground bounce and reflections. Once the jitters are added to the
signal it is impossible to remove them.
> It is difficult to relate the error and the failures after completion of the board. An
SI simulator is needed to rectify the problems before customers complain.

From the above analysis, it is clear that careful simulation, analysis, and
measurements of SI results are important in the reliable design process. To minimize the
risks of design failure due to high speed side effects, the designer should soon judge
design considerations such as allowing a wide timing tolerance, high noise margins, and
using circuits that are as slow as possible for the application early in the process. The
simulations tools are used to analyze the circuit design and define the design rules for
signal integrity, EMI and thermal and reliability issues very early in the design phase.

1.3. Thesis overview:

> This thesis discusses the design process for generic and high speed digital PCB
design using Cadence® Software. In the process of PCB design, the schematic
capture, library management, layout, and simulations of the board are discussed.
PCB design using ADS software and executing simulations on the board are also
described.
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> Chapter 2 discusses the design process of PCBs using Cadence® Software. It
provides detailed description of each process in the design flow for the PCB.
Design examples that explain the design process of the PCBs are also discussed.
^

Chapter 3 discusses designing a schematic and generating layout and simulations
connate to the PCB using Advanced Design System (ADS) that will give a novice
a quick start. This chapter will discuss simulations and measurements of example
interconnects that illustrate high speed issues in digital design.

> Chapter 4 provides a brief understanding regarding the simulations of a high
speed board using Cadence® SPECCTRAQuest™ and gives a brief discussion of
using SQ Signal Explorer.
> Finally, suggestions for future work including an extended understanding
regarding

the

simulations

of

a

high

speed

board

using

SPECCTRAQuest™ and SQ Signal Explorer are outlined in chapter 5.

Cadence®
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2. BASIC DESIGN AND LAYOUT
The design process of Printed Circuit Boards (PCBs) using Cadence® software
tools is shown in Figure 2.1. Each process is explained in extensive Cadence® tutorials
so the designer is able to follow the step-by-step process of the design examples. Project
Manager provides the umbrella tools for managing a design project. Design entry is
performed in Concept HDL, which also provides tools to translate a schematic to physical
description required by the PCB layout software. Layout is performed in Allegro®,
which also provides tools for generating manufacturing output files. The synchronization
between Concept HDL and Allegro®, as well as all part library functions are managed by
Project Manager.

Figure 2.1

Design flow for printed circuit boards [Cadence®, 2003a]
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This chapter provides a synopsis of the extensive Cadence® tutorial through two
progressively more complicated tutorials that will explain how to create a basic schematic
using Concept HDL and a PCB layout using Allegro®. An overview of each step in the
design process is given below.

2.1. Design flow for printed circuit boards
2.1.1. Project creation and setup
To start a project, first create a new folder where Project Manager will store all
files related to the project. Next, create a project by launching Project Manager. Project
Manager is the launching pad for all PCB system division tools. Using Project Manager,
the designer can launch all the tools in the board design flow for initializing and setting
up a design project using project setup, capture the logical design using Concept HDL,
package the design and perform placing and routing operations using Allegro® on the
design.
By creating the design project using the new project wizard in Project Manager,
the designer can change the default setup information that governs the project files. The
designer can add or modify the libraries in the project and also specify setup information
for various tools in the design flow. Further steps will be explained in the design
examples. After creating the design project, the designer will use a library management
tool; explanation follows.

2.1.2. Library management
The design process begins by creating a logical design and then a board-level
design that translates the logical design into a manufacturable entity. To accomplish this,
the designer initially must gather the required information for all parts used in the design.
All parts need to be available in the existing libraries. There are three different types of
libraries:
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Schematic libraries —These libraries have views for design entry or schematic
creation.

These

views

include

information

about

logical

symbols

(graphical

representations of the parts), pinouts, and packaging information.
Layout libraries - These libraries are needed during board layout; they contain
the footprints (mechanical representation of the part) that are linked to the physical parts
listed in the schematic libraries.
Local libraries (also known as design libraries) - Designers uses these libraries at
the local project level. At the local project level designers can import reference libraries
and change them according to the design requirements or designers can use the reference
libraries without any modifications. If the part does not exist in the libraries, Part
Developer in Project Manager can create a new part or modify an existing part. A
detailed description of Part Developer will be covered later in the design examples.

2.1.3. Design entry
After obtaining all the components required for circuit design, the designer,
engineer or both should discuss and decide by what method the schematic should be laid
out and how large the board should be. Design entry in the PCB design flow is done
using the Concept HDL tool. Concept HDL creates projects, places components (parts),
connects them, names signals, adds ports, and saves designs. When a design is saved,
Concept HDL will check for errors and help in locating spots on the schematic where
connectivity errors have occurred.
2.1.4. Packaging the design
Packaging the design includes generating bill of materials (BOM) reports, running
electrical rule checks and generating a netlist report. The netlist describes how the pins of
each device connect to each other. After saving the schematic in Concept HDL, it is
packaged. Before exporting the design to Allegro®, the designer selects package design
options depending on requirements and then exports the logical design entered in
Concept HDL by translating the design into a physical design set for layout.
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2.1.5. PCB layout
The Allegro® layout tool generates all necessary design data for board
fabrication. The Allegro® tool imports all the components and connectivity of the design
from Concept HDL. Before placing the components in Allegro®, the designer create
mechanical elements i.e. define the board outline, route keepin, keepout boundaries and
design rules (properties and constraints). Then, the designer defines layers (cross section)
and places the components. Components can be placed automatically or manually.
Allegro® also does the routing (automatic/interactive). After creating the board layout,
the designer should check whether the schematic (Concept HDL) and board layout
(Allegro®) are synchronized.

2.1.6. Synchronizing schematic and board
Synchronization is needed for changes that occur either in the board or in the
schematic after the initial transfer of packaged information to the board. The changes
include modifying components, properties, connections, reference designators etc. These
changes will cause the schematic and the board to go out of synch. The designer can then
update the schematic and board by exporting the logic design from Allegro® or from
Concept HDL.
2.1.7. Creating the manufacturing output
The final step after updating the board is to generate the manufacturing output
from Allegro®. The board manufacturer will require several forms of manufacturing
output such as drill file, silkscreen file, etch file for each layer, soldermask file and
drafting information about the size of the board. The drill file contains information on
where holes on the board should be drilled. This is usually given in the form of a drawing
with a drill table legend as well as some output files. Silkscreen information specifies the
location of text on the front and back of the board. The etch files contain information
about the copper signal traces and power planes in Gerber format. The soldermask files
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(top and bottom), specify the areas of the board that are masked from surface solder
finishing.

2.2. Design example-I
To show you how to apply the above information we will walk through design
examples together. This section will demonstrate the major tasks involved in project
creation and setup, creating the schematic using Concept HDL and the layout in
Allegro®, for a simple board (temperature board). The process involved in design
example I is divided into three sections:

> Creating a project
> Design entry using Concept HDL
> Packaging the design
'P Layout with Allegro®
Figure 2.2 and illustrates the complete schematic in Concept HDL, Figure 2.3
illustrates the final layout in Allegro® for the Temperature Board.

2.2.1. Creating a project
Before creating a project, first add a new folder in the directory where you want to
place the project and rename the folder

tempe. To create a p

Manager. Start Project Manager. On Windows machine, choose Start>Programs>
Cadence

P S D 1 51. >Project M
anager.Select PCB Design Expert and click Ok.

Project Manager appears (see Figure 2.4). Click Create Design Project. In the
New Project Wizard - Project Name and Location dialog box (see Figure 2.5) enter
the name of the project. For this design, name the project
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Figure 2.2

Final schematic for temperature board
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Figure 2.3

Final layout for temperature board

Figure 2.4

Project Manager

New Project Wizard - Project Name and Location

This Wizard steps you through the process erf
creating a new project.
Enter the name and location for your project.
Prqect name:
jtempe ratur e_ boarc|
Location:
Idatem per atu re

Figure 2.5

New project wizards - project name and
location
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X]

Select the libraries needed for this project. To change the search order of the Project
libraries, select the libraries and press the Up or Down buttons.
Available Libraries:
1 shot
100e
lOOel
10Oelt
100k
lOOkh
10Olvel
10e
lOel
10elt
10k
10kh
54alsttl
54asttl

Z3

Add ~>

Project Libraries:
temperature board lib
standard

Remove <-

Up
Down

fell Add All->
ill
IPI Remove All <
111

M

< Previous

Figure 2.6

Next >

Cancel

New project wizard - project libraries

Enter the location by using the Browse buttons. Specify the location of the
project. This will be the temperature folder you created before setting the project. Click
Next. The New Project Wizard - Project Libraries dialog box appears as shown in
Figure 2.6.
In this dialog box notice that the

pra<si added to the project
tem

libraries by default. You can select the libraries needed for the project by selecting the
library from the available libraries and clicking Add. After adding all the libraries you
need for the project, click Next.
Now the New Project Wizard-Design Name dialog box appears as shown in
Figure 2.7. Select temperature_boardJib as the design library. Enter the design name as
temp, which will become the top-level drawing for the design placed in the
temperature boardJib library. Click Next.
A New Project Wizard - Summary dialog box will appear (see Figure 2.8).
This will enter all the information you have specified. If you want to modify the details,
click Previous to go back. If not, press Finish to create the project.

19

Figure 2.7

New project wizard - design name

New Project Wizard - Summary

Press the Finish button to create your project or use the
Previous button to go back and change some options.
name: temperature_boarqBH
location: D:\TEM PERAT IJREl]

C'1? igrvflHljp
name:

library: temperature boardJitBI
location: D:\TEMPERAHjRE1SwQrklit

< Previous 1

Figure 2.8

Finish

1

Cancel

New project wizard - summary
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Figure 2.9

Board design flow

Project Manager has created the project and displays the board design flow (see
Figure 2.9). Project Manager has created a project file called temperature_board.cpm in
the project directory. The file includes the following setup information for the project:

P The name of the top level design and the library in which it is located.
> The list of project libraries.
P The name and location of the text editor for editing text files from Cadence®
tools.
> Setup directives for individual tools such as Concept HDL and Packager XL,
Programmable IC and Allegro®.
P Directives for customizing Project Manager (a customized tools menu or
customized flows).
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View the current session name and project settings by choosing View>Project
Settings in Project Manager. Now, if you want to modify the project library, click Setup
in Project Manager and you can select the libraries to be added to the project library.
You can also add new libraries that are not available in the available libraries by clicking
Edit.
Cds.lib defines all libraries in the schematic design and maps them to their
physical locations. Add DEFINE

librarynamejib librarynameJ ib in th

This will add the library to your project library.
Click Ok after making changes to your library. Before proceeding further, check
whether you have all the parts required for the design. In this design we will consider that
it has all the parts in its libraries.

2.2.2.

Design entry in Concept HDL
In this section you will learn how to create a basic schematic in Concept HDL. To

create a schematic for design example-I:

1. Define a physical part table for all components
2. Create the schematic page
3. Place components
4. Wire components
5. Add power, ground and ports

2.2.2.I. Define physical part table for all components
Physical part table (ptf) files store the packaging properties for a part in the
library. This file contains information about parts such as package types, manufacturers,
part numbers and any custom properties. Each physical part must have an entry in the .ptf
file in order to package properly. To launch part table from Project Manager, choose
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Figure 2.10 Open existing part
Tools>Library Tools>Part Developer. If you want to open an existing part click
File>Open>Cell and the Open Cell window appears (see Figure 2.10). At this point you
can select any cell (element) from any library defined in the Project. Select OK to edit
the resistor cell. To create a part table for resistor, right click on Part Table Files as
shown in Figure 2.11. Select New and accept the default name (part.ptf).
In the partptf window, under the part there are two options, Header and Part
Row. They appear on the right side of the part table as shown in Figure 2.12. The Header
contains two types of properties, key properties and injected properties. Key Properties
are the properties for the components that will not change. They are the standard
properties for the components and include VALUE, TOLERANCE, etc.

Injected

Properties are the properties that will vary. This includes the PWRRATENG,
PART_NUMBER, JEDECTYPE, MANUFACTURER, etc.
Select part row in the tree area to specify information for that specific part row.
For now take the resistor part in the temperature board and enter the following data for
3.3 kO resistor in VALUE - 3.3 k, TOLERANCE - 5%, PWR RATING - 0.25 W,
JEDEC TYPE - RES600, PARTNUM BER - 30672 and MANUFACTURER JAMECO. Then click Add. For resistor 600 12 and 10 kO thermsistor enter the data in the
same way as for 3.3 kI2 resistor shown in Figure 2.13. Save the part table by selecting
File>Save and exit part table by selecting File>Exit. Finally save the whole part by
selecting File>Save. To verify the schematic for packaging the part, choose
Tools> Verify. Then select View Verification and click Verify. Click Ok.
For this design create the part tables for the components listed in Table 2.1.

Figure 2.11 Part Developer
-In i

For Help, press FI

NUM

Figure 2.12 Part table file- header

x|

£
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Figure 2.13 Part table file- part rows

Table 2.1 Part tables for all the components in the temperature board
Key Properties

Component Value

Injected Properties

Tol

PWR_

Jedectype

Part_number

Fwdcur

Rating

Manufacturer
Distributor

Resistor

10 k-THERM 10%

0.5 W

RES400

207036

NA

JAMECO

Resistor

680

5%

0.25 W

RES600

30672

NA

JAMECO

Resistor

3.3 k

5%

0.25 W

RES600

31499

NA

JAMECO

Capacitor

0.1 uF

10%

50 V

CAP300

25523

NA

JAMECO

Capacitor

0.1 uF-ND

10%

50 V

CAP 1000

P3521-ND

NA

DIGIKEY

555B

555B

NA

NA

DIP 8 3

27422

NA

JAMECO

LED

Red

NA

NA

DIO 100

34645

20mA

JAMECO

Connector

2 pin

NA

NA

JUMPER2

NA

NA

NA
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PCB Design Expert: Concept-HDL - [TEMP,SCH. 1.1 [In hierarchy]]

Component

Wire

Text

Block

Group

Display

PSpice

Tools

Window

Help

Replace,
Version

Library View j Category View |
Library: [standard
Bubble Pins
Smash

Ei&er p

j
Search Stack.

4 MERGE
5 MERGE
GMERGE
7 MERGE
8 MERGE
9 MERGE
10 MERGE
A SIZE PAGE
ALIAS
AQUTPQRT
BIT TAP
BUFPORT
New Window.

Physical

Adding part B SIZE PAGE

Adds a component

Figure 2.14 Page border

2.2.2.2. Creating schematic page
After creating physical Part Table Files for all the components in the basic
schematic, you need to enter the schematic. Click Design Entry, which will open in
Concept HDL. The initial step before placing components is to add a page border. The
page border displays the design name in the title bar and other information about the
schematic. Choose Component>Add as shown in Figure 2.14.
Select Standard Library to place the page border. Select A Size Page for this
board. Click in the design window to place the page border. If you want to add the page
border automatically choose Tools>Options in the Concept HDL window and select the
size of the page with the browse button and then click Ok. In the Concept HDL window
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choose File>New. Now you can see that the page border is added. For now hit
File>Return to return to the original schematic. To add notes in the page border, choose
Text>Notes. Enter the notes and click the location to place the notes.
2.2.2.3. Place components
After placing the page border, place the components. The components are stored
in different libraries. Choose Component>Add to add components from the libraries as
shown in Figure 2.15.
You can add new libraries to the project libraries by clicking Search Stack next to
the filter in the Add Component window. Then in the Search Stack window, click edit
to add/remove the libraries from the available libraries to the project libraries. This is
shown in Figure 2.15. For the temperature board select the following libraries: standard
(B type page), element (resistor, capacitor, connector, LED, GNDA) and anl_misc
(555B). After adding the needed libraries for the project, Click Done and Close to end
the search stack.
To add components choose the part to be added and then click Physical to get the
properties attached to the part, which was placed for the parts in part table files. For
example add capacitor as shown in Figure 2.16. You can also change the symbol for the
part by selecting the part and right clicking on it. Select Version.
For LED part it has 4 versions by choosing Select Version and any one of the four
options as shown in Figure 2.17. The 4 versions for LED part are shown in the Figure
2.18.
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Library View
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ATTENUATOR
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CONNECTOR
COUPLE_T I
CURRENT PR1
CURRENT_SO Search Slack:
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New Window.
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Figure 2.15 Adding components

Figure 2.16 Add component - adding libraries to project
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Figure 2.17 Version for LED part

Figure 2.18 4 different versions of LED
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Figure 2.19 Pin numbers for a 555B component
You can get the pin numbers for the part by selecting the part. For example you
can see pin numbers for part 555B in Figure 2.19 by Right clicking on the part and
choosing Section. If you select Section once again, the pin numbers will be removed.
Choosing Attributes will display the properties of the part. You can see the
attributes (properties) for part 555B in Figure 2.20.
You can also add properties to the part by clicking Add in the Attributes window.
Choose None or Value to show the properties in the Design window. The Open option
contains sym _l, entity, chips, and part table:
Sym _l - contains the schematic symbol. The schematic for 555B part is shown in
Figure 2.21. In this window you can also change the position of the pins by selecting
Edit>Move (see Figure 2.21).
Entity — contains a master pin list. This view is generated when you save a
schematic symbol.
Chips - maps the logical part to the physical package.
Part table - contains additional properties. This helps customize the part for a
company.
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Figure 2.20 Attributes for 555B part

Figure 2.21 Schematic for the 555B part
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Figure 2.22 Wiring the components

2.2.2.4. Wire components
Now, after placing all the components in the Concept HDL design window, the
components should be connected by choosing

Wire is added from one pin

to another by clicking at the tip of one pin and then clicking at the tip of another pin to
which it supposed to be connected. You can change the direction of the wire by right
clicking and selecting Orientation (see Figure 2.22).
While wiring the pins you should see that the wire starts at the tip of the pins. It
should not cover the pin. After wiring all the parts, name the wires by choosing
Wire>Signal Name.
Enter the name you want to assign to the wire as shown in Figure 2.23. You can
name all the wires at once by typing the name of the wire and clicking Enter. Then enter
the next wire name and continue on. Now, click on the wires one after the other to place
the signal names you entered.
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Figure 2.23 Adding signal names

2.2.2.5. Add power, ground and ports
Power and ground pins are added to the design after wiring the parts and naming
the wires. The power and ground pins are found in the elements library. To add these pins
choose Component>Add and select the element in the Library Cell. Choose the power
and ground pins depending on the needs of the circuit (see Figure 2.24 ). The ports are
added to the wires, which are found in the standard library. Inport, outport or ioport ports
are selected on the requirement of the design.

2.2.3.

Packaging the design
The next stage is to package the design. After saving the design, if there are any

errors you can locate them by clicking on the error. Then the marker will point out the
place where there are errors. After removing all the errors in the design, save the design
and package it by choosing File>Export Physical in the Concept HDL window as shown
in Figure 2.25 or by choosing the Design Sync icon in Project Manager window and
click Export Physical.

Figure 2.24 Adding ground and port pins

Figure 2.25 Export physical
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The Export Physical - temperatureboard.cpm dialog box will be opened for
the design; it will have following options:

Package Design:
To package the design before updating the layout data, select the package design
check box. You have the following options in packaging:
Preserve - Packager-XL will select Preserve as the default option. When
Preserve is selected Packager-XL will preserve all the previous packages and only
changes made from the last packaging run will be added.
Optimize - Packager-XL uses Optimize to package the schematic data into a
compact physical design.
Repackaging - the Repackaging option is selected to ignore all the previous
package results and will repackage the design. You can change the Packager-XL
setup by clicking the advanced button.

Regenerate Physical Net Names:
If you want to regenerate physical net names, select the Regenerate Physical Net
Name check box.

Update Allegro® Board (Netrev):
Select Update Allegro® Board (netrev) to update the Allegro® board.

Update Allegro® Board Option:
Specify input and output board files, for temperatureboard:
Input Board File - Enter the name of the existing Allegro® file

(TEMP.BRD)

that needs to be updated in the input board file field.
Output Board File - Enter TEMP.BRD in output board files.

If youenter the

same name in the input board file field as in the output board file, the board will
overwrite the existing file.
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Allow Etch Remove during ECO:
To make Allegro® rip up the etch from a removed pin, select the Allow Etch
Remove during ECO check box.

Place Changed Components:
To select the option for placing changed components in layout from those made
available by Packager-XL, select one of the following 3 options:
Always - This is the default selection. Allegro® will automatically replace all
components in Allegro® with the new components from Packager-XL according to
their reference designators.
I f same - Allegro® will automatically replace all components in Allegro®
with the new components from Packager-XL only if the replacement component
matches the package symbol, value and tolerance of the component in the layout.
Never - Allegro® will never replace any component in layout with the new
component. You must make changes interactively.
BackAnnotate Schematic:
Select the BackAnnotate Schematic check box to back annotate the latest package
and constraint information to the schematic.In the export physical dialog box, click Ok. In
design example-I, before doing the packaging click Allegro® in the PCB Design ExpertProject Manager. Then choose File>New in Allegro®. Select the board and name it
TEM PBRD in the new drawing window. Click Ok and Save the new drawing you
created. Now, again switch to the Concept HDL window of the design. Then choose
File>Export Physical. The Export Physical window will appear. Select the Package
Design and Preserve option. Check the Update Allegro® Board (Netrev) and name the
input board file and output board file TEMP.BRD. Select the Always option in the place
changed components section of the dialog box. Select the BackAnnotate schematic. Then
click Ok to package.
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Figure 2.26 Progress

The progress window appears as shown in Figure 2.26. The progress for design
example-I will be in the following order:

> Netlisting design
> Packaging the design
> Updating Allegro® board
> Backannotating design

The information in the Progress window will change based on the options
you selected. After successful completion of the export, you can click

to view the

results in viewlog. After you have done the packaging successfully, you can:

> Generate the BOM for your design
> Run the electrical rule checks
>■ Generate the netlist report

You can get all of the above utilities by using package utilities. To launch
Package Utility, the following steps should be performed. Choose Tools>Package
Utilities and select Bill O f Materials in Project Manager. A bill of materials (BOMs) for
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the design is generated now. You can change the path for the BOM. You also can change
the format of the file generated by selecting Tools>Package Utilities - Electrical Rules in
Project Manager. The Electrical Rule Check dialog box will appear. Select all the
check boxes and click Run to check the electrical rules.
You can also generate a netlist report by choosing

Utilities -

Netlist reports in Project Manager. Netlist reports is generated when you save the
design in Concept HDL, which allows you to generate the viewlog or VHDL netlist.
Now, after the packaged design is ready for board layout in Allegro®, the final physical
form of the circuit will be determined.
2.2.4. Board layout in Allegro®
To start the board layout click Allegro® in Project Manager window. A blank
drawing window will appear.

You can move, copy, mirror, spin, and delete the

components when you choose Edit. You can also make those tools visible on the
Allegro® window by selecting View> Customization and click Toolbar to display the
customized dialog box. Now, you can select the Edit check box to display all the tools for
editing the board. Similarly, you can select other check boxes to display them in the
window.
A designer can set the colors for the board according to their requirements and
save those colors in the library. Choose File>Script and enter the name under which you
need to store the colors. Click Record. Now, make changes in the color palate by
choosing

Display> Color./Visibility.After completing the changes in colors and visibility,

click Ok. Once again, choose File>Script and click Stop to exit the recording of the
colors to the file you indicated.

If you want to see the colors you selected, choose

File>Script. Click Library to get the file where you saved your favorite colors, then click
Replay.
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Figure 2.27 Creating board using board wizard

2.2.4.I. Create mechanical elements in Allegro®
The first step is to create the mechanical elements i.e. to draw the outline, route
keepin and keepout area for the board by choosing File>New as shown in Figure 2.27.
Then a New Drawing dialog box appears; select Board (Wizard) and enter the
name as TEMP.BRD. This name was specified during exporting in the Concept HDL
window. Select the Board (Wizard) option to create the outline, route keepin and package
keepin automatically. Then Click

Ok.The Board Wizard dialog bo

Next. The Board Wizard-Template window is opened. If you do not have any template
to load, select No and click Next. Now, the Board Wizard-Tech File dialog box appears.
If you have any files click Yes. But for our board select No, and click Next. Board
Wizard- Board Symbol page is opened. Choose No for the board symbol you want to
import to this board. Click Next. Enter the units, board size, grid space and etch layer
count for the board drawing in the General Parameters dialog box then click Next.
Define the spacing constraints for the board for design example-I. The spacing
constraints are taken to be 10 Mils (see Figure 2.28). Click Next.
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Figure 2.28 Spacing constraints
The board outline is a rectangular board for this example. Choose Next. Specify
the width and height of the rectangular board outline. Also specify route keepin and
package keepin spacing from the edge of the board as shown in Figure 2.29.

Figure 2.29 Board parameters
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Figure 2.30 Created outline of the board
Finally the board mechanical elements are created. Click Back to make any
changes. Click Finish. The board is created (see Figure 2.30).

2.2.4.2. Component placement in Allegro®
Before placing the components the designer needs to import the design logic from
Concept HDL by choosing

File>Import>Logic.The components are pla

drawing environment by choosing Place>Quickplace (see Figure 2.31).

1
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Figure 2.31 Quickplace

The Quickplace dialog box appears. You can specify the location of each
component. Click Place to place the parts and Ok. You can also place the components
manually by selecting Place>Manually, which places the components outside the board
outline as shown in Figure 2.33.
Move the components from outside the board into the board accordingly by
choosing Edit>Move.
After placing all components as shown in Figure 2.32, place the mechanical holes
at the four comers of the board.
Choose

Place> Manuallyin the Placement dialog box. In mechanical symbols

there are tooling comers. You can complete the temperature board as in Figure 2.3.

Figure 2.33 Components placed outside the board
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2.2.5.

Creating manufacturing outputs
After completing the temperature board, send it to the manufacturer for

fabrication. The board manufacturer will require several forms of manufacturing outputs
from Allegro®. Manufacturing output requires several things:

> Drill information, which indicates where to put various sized holes on the board.
This is usually given in the form of a drawing, which has a drill table legend as
well as some output files.
> Silkscreen information, which is the location of text on the front and back of the
board.
> Photoplot information, which is the artwork in Gerber format for each of the
layers of the board, including soldermask (top and bottom), etch layers and power
plane layers.
> Drafting information about the size of the board.

In general, manufacturing output of all forms (text, etch etc) is created using
layers on the board that are currently visible. This means that for each layer you generate
output for, you will need to first edit the color table and make visible only the
information that should be present on the particular layer.
2.2.5.I. Creating drill information
To create the drill information for the board, first set the color visibility and make
visible only the outline in the geometry group, the NCDrill-Legend and the NCDrillFigure in the manufacture group. Set the pin class (entire) and the via class (entire) in the
stack up group. Choose Manufacture>NC>Drill Legend.

Figure 2.34 Drill legend
Give the title for the legend (MY DRILL CHART) and enter the Plated Hole
Tolerance as 0.004 and the Non-Plated Hole Tolerance as 0.006 as shown in Figure 2.34.
Click Ok and place it outside the board outline. Usually place the drill table off to the side
of the board out of the board limits. This creates a drill table only for currently visible
holes and pins and all vias regardless of their visibility. Generate the output parameters
for the drill files by choosing manufacture>NC>Drill Parameter and enter the file name
as myd.rill.tap and the header as my tape data as shown in Figure 2.35.
Check Separate plated/non-plated. Click

To generate the drill files, choose

Manufacture>NC>Drill tape and enter 1 in the scale factor box. Click Run. This will
generate two files called mydrill.tap and nctape.log, which contain drill tape parameters.
Save these. The character for each drill hole is set in the padstack. Modify the padstack
used by selecting

Tools>Padstacks> ModifyDesign Padstacks and select the cor

padstack. Then select the ncdrill and change the drill table character.
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Figure 2.35 Drill parameters

2.2.5.2. Creating silkscreen information
Silkscreen information can be generated automatically from information on the
board. The first step in creating the silkscreen is to set the text of the reference
designators of the components in silkscreen top by choosing Edit> Change. Set the active
class and subclass as ref des and silkscreen top respectively in the options tab of the
control panel. Adjust the text block below, which changes the size of the text. You must
move the ref des into the components such that the text is within the component outline,
which can be done by using the Find tab in the control panel by selecting only Text. This
will avoid errors while creating silkscreen. Select Edit>Move to move the text. Then
Manufacture> Silkscreen.

choose

Typically use the following subclasses as shown in Figure 2.36 to generate
silkscreen:
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Figure 2.36 Creating silkscreen

> Board geometry- none
>• Component value-none
> Device type-none
y

Package geometry-silk

> Reference designator-silk
> Tolerance-none
> User part number-none

In

textrotation check 0. Enter the value for maximum displacement as 250,

displacement increment as 1 and element to pad clearance as 7. Then click Audit. Notice
whether the command window gives 0 errors. Then choose Manufacture>Silkscreen.
Click Silkscreen to get the silkscreen information.
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2.2.5.3. Creating photoplot information
Photoplot information is generated in the board. To create the actual files it is
necessary to run another program external to Allegro®. Select
You need to give information about the artwork layers you will be creating. Before
adding artwork layers you need to set the color visibility. Here are some suggestions for
what to make visible for each of the different artwork layers. Obviously the layer names
can be changed and you can add different layers as necessary. These layers are for a
board with two layers (see Figure 2.37):

> Board Outline
Board geometry-outline
Board geometry-NC_Routepath
> Bottom Etch
Board geometry-outline
Etch-bottom
Pin- bottom
Via class-bottom
> Bottom SM
Board geometry-outline
Board geometry-soldermaskbottom
Package geometry-soldermask_bottom
Pin-soldermask_bottom
Via-soldermask_bottom
> BottomSilkscreen
Ref Des-assembly_bottom
Board geometry-outline
> Top Etch
Board geometry-outline
Etch-top

Figure 2.37 Creating films to generate photoplot information

Pin-top
Via class-top
T opS M
Board geometry-outline
Board geometry-soldermasktop
Package geometry-soldermask_top
Pin-soldermask_top
Via-soldermask_top
Top_Silkscreen
Ref Des-assembly_top
Board geometry-outline
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Figure 2.38 Setting the general parameters for artwork

When you have completed all the films, select General Parameters (see Figure
2.38). This generates the files art_param.txt, which you will need to include with the
manufacturing output. Next, select Aperture. Be sure the wheel is set to 1. Select
Edit>Auto>Done. This automatically generates the art_aper.txt file. It can be overwritten
if necessary.
After creating the manufacturing outputs for the board required, send these files to
the manufacturer for fabrication. Now you will see design example II which deals with a
more complicated board.
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2.3. Design example II
This section deals with designing a PCB for the MSS (Micro Sensor System)
power supply board, which includes the following:

> Creating a hierarchical schematic entry using Concept HDL.
>

Creating library parts for Concept HDL.

>

Creating library parts for Allegro®.

>

Creating power planes.

>

Check DRC (Design Rule Check) errors and

creating manufacturing outputs.

The information in design example-I set the stage for what you are going to learn
here, where the board is designed. As we discussed in design examples I, the first task in
designing a PCB is to create a project which is similar to the project creation of the
altimeter board as discussed in the previous section. For design example II, enter the
name of the project as MSS PS.
This design example is written to instruct the design process, including: advanced
design entry because of the complexity of the board, creation of parts for Concept HDL
using Part Developer, board layout in Allegro® using a multilayer stackup, creation of
symbols or footprints, creation or modification of padstacks for layout, and determination
of how to utilize the other tools for deigning a PCB. Figure 2.39 shows an overview
schematic in Concept HDL. Figure 2.40 presents the final layout in Allegro® for the
MSS PS board.

Figure 2.39 MSS PS board complete schematic
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Figure 2.40 MSS PSS board complete layout

53
2.3.1. Hierarchical schematic entry in Concept HDL
In design example-I you learned how to enter the basic schematic for the design
where all the parts were pre-defmed in the library. In this section you are going to learn
how Concept HDL allows you to create and modify design schematics and symbols.
Schematics can be multi-page and you can link them together by naming wires. Concept
HDL does not check for floating wires so be very careful that you name them correctly.
In Concept HDL you can add blocks and create the schematics for each block.
Because of its complexity the full schematic for the MSS_PS board can not be
entered on a single page. To solve this problem we create a hierarchical schematic. A
hierarchical schematic looks like a block diagram where each blocks links to separate
schematic page. To add the block, choose Block>Add in the Concept HDL window.
Then begin drawing the block by clicking and dragging the mouse diagonally. Click
again to end drawing the block. Right click and choose done to complete the drawing
block. After adding the block, name the block by choosing the Block >Rename option
and enter the name of the block. Click Ok. To add the pins to the block, choose
Block>Add Pin and select the submenu depending on whether it is an input, output or
inout pin. Enter the pin names and place the pins on the block by clicking on the block.
To create the schematic for the each block, choose File>Open. Then the view
dialog box appears as shown in Figure 2.41. Select the library as

_ps_lib. Enter the

block name to which you want to add the schematic as the cell and select the schematic as
the view. Click Open, which will open the schematic page in the Concept HDL window.
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Figure 2.41 View open

In the schematic page, create the schematic in a similar manner as was discussed
in design example I. You can link all the blocks by connecting them using wires and
naming the signals. Add a new schematic page to the design by choosing File>Open.
Enter the

nameof the page in the cell and enter schematic as the view. Click Open. You

can view the schematic in the DCDC converter of 3.6 V block for the MSS PS board in
Figure 2.42. The complete hierarchy schematic drawings for the MSS_PS board are
shown in the appendix.
If some of the parts required for creating the schematic for the MSS_PS are not in
the Concept HDL library and the parts that are needed for layout are not in the Allegro®
library then they are created/edited using the Part Developer tool. Before building the
new part, collect the datasheet for the part.

Figure 2.42 Schematic in the DCDC converter 3.6 V block
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2.3.2. Creating library parts for Concept HDL
Part Developer is the tool for creating, editing and verifying part data. It can be
launched from the library explorer once the user has selected an existing part or named a
new part. Part Developer will perform the following:

> Create library entity
> Create symbol
> Create package
> Create Part table
The creation of the part table was discussed in section 2.2.2.1 and will not be
discussed further here. Part Developer will also check for errors ensuring that parts are
consistent and error-free. Part Developer enables you to create and modify symbol,
package, and part table views of parts in Concept HDL libraries. You should follow the
sequence of steps listed below to ensure an effective use of the Part Developer tool:
> Collect the datasheet for the part. The datasheet contains all the information
required to create the part.
^

Set Part Developer to correctly interpret the pin names.

> Enter the logical pin information i.e. pin names as they appear on the datasheet.
> Enter the values in the Setup Options to create a part. These values will depend on
the values in the datasheet and the standards you follow. These values include:
properties that are to be placed on the symbols, pins and packages, the placement
and enter values of the pins, the format of the symbols as they will appear in
Concept HDL, the format of the low asserted pins, and the interpretation of the
pin names.
> Create the packages for the part, which creates the chips view for the part.
> Create the symbols for the part, which represent the symbol views.
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Figure 2.43 Part to create using Part Developer [National

, 2005]

> If required, create the simulation views that involve creating the Verilog and the
VHDL wrappers and map files. This is beyond the scope of this thesis. See
Cadence® [2003c] for details.
> Verify the parts that you have created for use in the design flow.
2.3.2.I. Creating library entity
For instance, create the LM2653 1.5A high efficiency synchronous switching
regulator (see Figure 2.43) using Part Developer. The first task is to get the relevant
datasheet for the part and save it in the project folder for future reference. A snapshot of
the datasheet is shown below:
Part Developer is started by choosing Tools>Library Tools>Part Developer in
the PCB Design Expert window. The Create/Open Part dialog box in the Part
Developer window appears as shown in Figure 2.44.

Welcome to Part Developer. To create a new part or open an existing part,
choose the appropriate option from the following. T o do other operations like
setting up a template, importing intermedtiate save files / XML files, click on
the cancel button and choose the appropriate option from the menus.
Open Existing.

Cancel

Figure 2.44 Create/open part
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Figure 2.45 New part properties

To create a new part click Create New. To modify the existing part click Open
existing....Select the library in which you want to add the new part and then enter the part
name. The Physical Part Name field also gets filled in automatically as shown in Figure
2.45. Enter the part name field. This field is used as the PARTNAM E property in the
part table. Click Ok, and the logical pin dialog box appears as shown in Figure 2.46.

OK

|

Caned

|

Figure 2.46 Logical pins window

Help

|
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Figure 2.47 Setup options

2.3.2.2. Create symbol
Logical Pin Names appear in the datasheets in the following four patterns:

> Alphanumeric String (for example, A, B, and EN)
> <Alphanumeric String><Numeral> (for example, AO, A l)
> <Numeral><Alphanumeric String> (for example OA, 1A)
> <Numeral><Alphanumeric StringxNumeral> (for example 1A1, 1A2)

Notice that any string that is determined by alphabets on both sides is treated as
an alphanumeric string, for example, A, Al A. Click Edit in the Pin Name Interpretation
group box in the Logical Pins dialog box. Then the Part Table Setup options dialog box
opens. Select the Pin Nam/Interpretation tab as shown in Figure 2.47.
Select Base Name in all three sections so Part Developer will interpret all pins as
scalar pins. Click Ok. Part Developer is now setup to start creating the parts.
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Figure 2.48 Logical pins

Pin information that is entered into Part Developer is taken from the pin
descriptions table in a datasheet of the part. Pin sequences are entered in the same way as
they appear in the datasheet. Select the pin type as INPUT.
Notice that the type dialog box INPUT is selected by default. If the logical pin
names for input pins are in sequence like AO, A1.... A10 then it is not necessary for you
to enter each and every pin separately; just specify each as A0-A10 in the Pin Name box.
Click Add to add the specified pin names. This gets into the logical pin list.
Repeat the above step for the different pin types of the part. After entering all the pin
information, the Logical Pins dialog box for LM2653-ADJ appears as shown in Figure
2.48.
Click Ok to accept the entries of the Logical Pins dialog box. The next step is to
create a package.
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Figure 2.49 Packaging
2.3.2.3. Create package
To create a package for LM2653ADJ, right click on the package and select New
in the PCB Design Expert: Part Developer window. Then the New Package window
appears. In this window you can specify the package type, the footprint for the part and
map the pins to the physical pin of the footprint.
For LM2653ADJ enter the package type as IC and JEDEC_TYPE as tssopl6 by
clicking the Specify Footprint button. If the footprint for the part already exists in the
library, click on the Browse button to select it. You can also view the footprint in
Allegro® by clicking the View button in the Physical Properties window as shown in
Figure 2.46. Additional properties for the part also can be entered on the general page in
the New Package window.
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Figure 2.50 Physical pin mapping
The Physical Pin Mappings page will appear when you click the Physical Pin
Mapping tab in the new package as shown in Figure 2.47. This page allows you to add
physical pins and map them to the logical pins.
Select the Extract from Footprint button to get the physical pin list from the
footprint. Click Pin Numbers. Then a message box appears which informs you that all pin
numbers extracted from the footprint will be added as unmapped pins to the package.
Click Ok. This lists all the extracted physical pins from the footprint of the part under the
Physical Pins list in the Physical Pin Mapping Property dialog box. Notice that the
Physical Pins list is not in order as shown in Figure 2.50. To sort according to numeric
order, click the Number column heading. Next, map the physical pins to the logical pins
as per the datasheet. According to the datasheet, physical pin 6 is mapped to the logical
pin VCB. Therefore, select VCB in the Logical Pins list and 6 in the Physical Pins list
and click Map. This maps the physical pin 6 to the logical pin VCB. Similarly, map the
other logical pins to the respective physical pins. After mapping all the pins, click Ok to
complete the creation of the package. You can also create multiple packages for a single
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part by right clicking on the LM2653ADJ_IC package in the tree view and selecting
Copy. Then right click on the Packages entry in the tree view and select Paste. You can
see that a copy of the LM2653ADJ_IC package is created with the name
[1], To modify the properties of this package, right-click on the

[1]

entry in the tree view and select Properties. The Package Properties dialog box appears.
You need to make changes to the information, which includes package type name,
JEDECTY PE value and physical pin mappings. First, you will change the package type
name i.e. Change the Package Type value from IC[1] to dip. Next, change the value of
the JEDEC_TYPE property from TSSOP16 to DIP 16 and at last change the footprint
information by clicking Specify Footprint. Then the Physical Properties dialog box
appears. Click the Browse button. The Footprints dialog box is displayed. Select dip 16
and click Ok. Next, update the pin mappings. Click Physical Pin Mapping. After you
complete the mappings, click Ok. Now you have successfully created the IC package for
the LM2653ADJ part. After you create the packages for a part, you need to create the
symbols for the part. Before creating a package/part symbol you should have the
following specifications:
>
>
>
>
>
>

Pin to pin spacing for a part
Pad size
Drill size
Component origin
Insertion machine clearances
Component body size
Also, you should create the library padstacks associated with the pins in the

components. After creating the part you should create physical part table for the part in
the same procedure as described in design example-1.

2.3.3. Creating library parts for Allegro®
Before creating a package/part symbol you should check whether each pin in a
symbol has an associated padstack, which are in the padstacks library. If not you should
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Figure 2.51 Pad designer window
create padstacks before going further. To create a new padstack, go to the PCB design
expert: Project Manager window and choose Tools>Library

Editor.

The Pad_Designer window opens as shown in Figure 2.51
Before creating a new padstack, check that the padstacks do not already exist in
the padstacks library by selecting

Yile>Openin the Pad_Design

choose File>New... and name it SMD180REC40.pad. Now, you are going to see how to
create a rectangular - shaped surface mount pad, 180 x 40 Mils pad size with top/surface
mount. After getting all the data required to create the padstacks, which includes type
(through, blind/buried or single), drill hole information, drill symbol and dimensions of
padstack layers (regular pad, thermal pad and anti pad for all the layer involved in
creating padstack). Enter all this information in the Parameters and Layers tabs of the
Pad_Designer window for SMD180REC40. The padstack is shown in Figure 2.52 and
Figure 2.53.

Figure 2.52 Padstack designer - parameters window

Figure 2.53 Padstack designer - layers window
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If you want to use similar information for padstacks sharing the same information
with few changes to the padstack specifications, choose File>Script in the
PadstackD esigner window.
You can also update the padstacks in the layout, which are modified after creating
the layout by choosing Tools>Padstacks>Refresh in the Allegro® main window. After
you have the padstack required for the symbol then start creating the symbol using the
Package Symbol Wizard.
You can create a symbol by using the Package Symbol wizard or using the
Package Symbol manually. To open the Package Symbol Wizard in Allegro®, choose
File>New and choose Package Symbol (wizard)', then follow the instructions in the
dialog boxes. Enter data and view visual representations of Package Symbol. When you
finish creating your package symbol, the corresponding symbol drawing is automatically
opened in the symbol editor. Now, you will create the LM2653-ADJ symbol by using the
package symbol wizard in Allegro®. In Figure 2.54 you will see the details of the
mechanical specifications from the datasheet.
Open the Package Symbol wizard in Allegro®. Choose File>New and choose
Package Symbol (wizard) in the drawing type option and in the drawing name option
TSS016 as shown in Figure 2.55. Click Ok.
The Package Symbol W izard dialog box will appear. Choose the package type
as SOIC (see Figure 2.56 ).
Click Next. Choose default Cadence® Supplied Template in the Template
Drawing file as shown in Figure 2.57. Click the Load Template button. Click Next.
In the General Parameters option select Mils in both dimensions and package
symbol. In the reference designator prefix select U as shown in Figure 2.58. Click Next.
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LM2653 1.5A High Efficiency Synchronous Switching Regulator
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Order Num ber LM 2663M TC-ADJ
Package
MTC16
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Figure 2.54 Physical dimensions for LM2653-ADJ p art [National
2005]

Figure 2.55 New drawing

,

Figure 2.56 Packaging symbol wizard

Figure 2.57 Package symbol wizard - template

Figure 2.58 Package symbol wizard - general parameters

Figure 2.59 Package symbol wizard - SOIC parameters

Figure 2.60 Package symbol wizard - symbol compilation

Figure 2.61 Package symbol wizard - padstacks
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To specify the SOIC parameters as shown in Figure 2.59, look at the physical
dimensions in Figure 2.54 of the datasheet. Click

Choose the padstack to be used by

clicking the button and selecting smdl80rec40 from a list of all the padstacks as shown in
Figure 2.61. Click Next.
Select the location of the symbol origin as Center o f symbol body. Select Create a
compiled symbol (see Figure 2.60). Click Next.
Finally, select Finish. You can go backward and forward through the wizard to
modify the package.
You successfully created the TSSOP16 symbol as shown in Figure 2.62 for the
LM2653ADJ part. After creating/editing library parts for Allegro® and creating new
padstacks to the library required for the parts in the layout of the M S S P S board, start
creating the layout in a similar procedure as discussed while doing the board layout in
Allegro® for design example I. The only additional task in this layout is that the layout is
done using 4 layers (top, GND, VCC, bottom layers). Do the MSS PS board layout in
Allegro® using all 4 layers as shown in the appendix.

Figure 2.62 Symbol for TSSOP16
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Figure 2.63 Reports
2.3.4. DRC errors and create manufacturing outputs

Finally check for DRC errors by choosing

the Reports dialog

box appears. Select Design Rules Check and click the Report button as shown in Figure
2.63. Rectify all the errors that appear in the Design Rules Check Report window as
shown in Figure 2.64. This will give the location (x and y coordinates) for the errors in
the layout and the type of violations (like package keepin, etch- to- pad violations so on).
After finishing the board layout successfully, create manufacturing outputs required for
doing board fabrication. Manufacturing outputs (drill information and silkscreen
information) for the MSS_PS board are created exactly in the same way as discussed in
design example I. But, while creating photoplot information, some additional changes
must be done since in design example I you set the color visibility in the artwork layers to
be created for two layers (top, bottom layers). So now, as the MSS_PS board contains 4
layers, add GND and VCC layers in the same procedure as it is done for top and bottom
layers in design example I.

2.3.5. Creating power planes
Depending on the need, select whichever shape fits for your design by selecting
Shape. For example, to create a rectangular shape for the ground layer for design
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Figure 2.64 Design rules check report
example - II, you will select Shape>Rectangular from the main toolbar and in the right
panel in Options tab select the following:

>

Active Class and Subclass - Gnd.

>

Shape Fill - Static Solid.

>

Click on the browse button next to Dummy Net to assign the desired net.
Here you will select Gnda and click Ok.

>

Segment Type - Line.

Start drawing the shape by clicking at the initial point and then drag to cover the whole
desired area and a click to end shape. The shape is voided automatically by selecting
Select Shape or Void. By selecting Manual Void you can void manually in what ever
shape you want.
Now, you can design the PCB using Cadence® software. But, while designing the
boards in this chapter we are not considering the high speed effects that are discussed in
chapter 1. The high speed effects on PCBs are explored in Chapter 3.

74
3. SIGNAL INTEGRITY (HIGH SPEED DIGITAL DESIGN)
High speed issues in digital design are considered to be the most challenging
problems for today’s digital engineer. The electrical performance of a circuit board may
be analyzed without regard to board traces (i.e. interconnects) only at low clock
frequencies or slow rise time. At clock frequencies above 100 MHz, edge rates about 1
ns, the electrical properties of interconnects approach that of transmission lines. Some
high speed issues which include timing analysis, reflections, crosstalk and losses, must be
considered depending on the edge rate of the circuit. Rise and fall times will determine
the maximum frequency of the circuit, which will decide the maximum length of a trace
on the board for which any traces longer must be considered transmission lines. If the
length of the trace is 1/10th of the edge rate then it should be considered transmission line
[Hall et

al.,2000],

The maximum frequencies and length of the trace is calculated in Table 3-1 for
different logic families by taking their typical rise times from datasheets.

Table 3.1 Different logic families

Logic Family

Rise time (ns)

Maximum
Frequency
(GHz)

Microstrip
Length
(Inches)

ECL10K [Coombs, 1995]

7

0.14

4.13

TTL [Coombs, 1995]

5

0.20

2.95

GaAs [Coombs, 1995]

3

0.33

1.77

AHC [Berrie, 2005]

2.4

0.42

1.41

ALS [Coombs, 1995]

2

0.50

1.18

ALVC [Berrie, 2005]

0.7

1.43

0.42

LVT [Berrie, 2005]

0.6

1.67

0.35
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The maximum length of interconnect for which the engineer can ignore
transmission line effect is equal to 1/10th of the edge rate on the board. The distance on a
trace that the clock edge occupies is given by Vp * Tr, where Vp is the velocity of
propagation on the board and Tr is the edge rate. The velocity of propagation is equal to
c / ^ , where c is the speed of light and FR4 material can have a range of er 3.9 - 4.3
[Leys, 2004], here we take er is 4. For a different dielectric constant, the length where
interconnect must be considered as a transmission line is different.

3.1. Explore high speed issues in digital design
Here we try and investigate some of the problems that are faced in high speed
PCB design by implementing simulations and measurements on an example interconnect
that illustrates high speed issues in digital design such as timing analysis, reflections,
crosstalk and losses.

Simulations
Simulations are frequently used today in many important applications: to
brainstorm and test the i f s and but’s of a real time scenario and to avoid the failures
before hand. The simulations can be used in highly sophisticated and extreme conditions
in order to take full advantage of the data used in the design that can not be incorporated
in real time situations. The example interconnects developed to illustrate high speed
issues in digital designs are simulated using Advanced Design System (ADS).
In 1997 HP EEsof introduced ADS. ADS is used as a platform for high frequency
design [Breed, 2001]. ADS tool is used to generate schematics, simulate setups, linear
simulations and tune and view results of common circuit designs. It also provides
complete high frequency design tasks, including simulations, layout and verification
solutions in a single and integrated design flow. It is the tool used by RF and digital
signal process engineers for creating complex communication systems.
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4.875, 2.250

Figure 3.1

Complete schematic of reflections circuit

You can learn about ADS tool by going through the long manuals of this program
[Agilent, 2003], This tutorial gives a quick start for novices by providing a step by step
approach of using ADS tool. In this quick start tutorial we will build a circuit to illustrate
the effect of impedance discontinuities in a transmission line. We will use a transient
simulation block to simulate the circuit. Figure 3.1 illustrates the complete schematic of
the reflections circuit.
First we need to launch the Advanced Design System window. Typically this is
accomplished by going to Programs>Advanced Design System 2003A>Advanced Design
System. This will bring up the Advanced Design system (Main) window of ADS as
shown in Figure 3.2. ADS has its own hierarchy when dealing with a file.
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|§ Advanced Design System (M ain)
File

View

Tools

Window

DesignKit

DesignGuide

Help

File Browser
a {& default
h -t.. ..
& CD 331board_prj
B CJ chap_4_prj
ffi O design_prj
SB- CH digital_design_pri
i O hpeesof
$ CD newdesign_prj
SB C] studio_files
8B Q test_prj
Be CD untit!ed_prj
(Double click to open
Use the File menu or the File Browser to open a project

Figure 3.2

Main window of ADS

To create a new project, in the Advanced Design System (Main) window click
File > New Project. Then specify the path and project name for the project to be stored
by using the browse button. For this example we assume that you will store your project
in a directory called ADS_projects (consider that this directory already exists in your
directory structure). ADS will create a project folder in the path specified with the name
specified. For example in the New Project window you would complete the Name field
with D:\ADS_projects\reflection_board and click Ok. ADS will append “_pij” 1° aH
project file names. ADS does not accept file names with spaces. While creating a new
project, a schematic window will also appear as shown in Figure 3.3 where components
can be placed and simulations can be setup.
Now we need to build the schematic to perform simulations. To place the
components select the approprate components from the left pane of the Schematic
window. Different components are made visible by selecting the appropriate library using
the pull down menu on the left pane of the Schematic window. The first component
which needs to be placed is TLIN. That can be found in TLines-ideal library from the pull
down menu. Select the TLIN and place it in the Schematic window. Hit escape to stop
placing the component and to cancel most commands in ADS.
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Figure 3.3

Schematic window

Its initial impedance, electric length and frequency, can be changed by double left
clicking the

INomponent.
L
T
c
For now we will leave all the characteristics at their default

values. The other components required are

Voltage Source and Resistors. Step

Voltage Source can be found in the Sources-Time Domain library and Resistor can be
found in the Lumped-Component library. Place two of the Resistor components, one Step
Voltage Source component and add two grounds which are selected from Insert>Ground
in the Schematic window. Connect all these components using the wire. All the
components placed are connected as shown in Figure 3.4.

Double clicking any

component in the circuit schematic brings up all the properties of the component.
Change the resistance values of R1 and R2, set up the appropriate source characteristics
as those shown in Figure 3.4. R2 is set to a large value to simulate an effective open
circuit.
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Figure 3.4

Complete schematic for transmission line model

To connect the components in the schematic with wire choose Insert>Wire. Each
component has a red dot at either end of the component. To connect the resistor and
components click on the red dot of the resistor once and then on the red dot on one side
of the TLIN component. They are now connected as the red dots at the ends are changed
to blue dots. In the same way connect the remaining components in the schematic as
shown in Figure 3.4. Other than having the dummy circuit, the schematic must have the
simulation block to specify what kind of simulation you want. For this circuit we opt to
do the transient simulation. Change the library to Simulation-Transient and select Trans
block, which will make ADS aware that this is an transient simulation. This block does
not connect to anything, it tells only what type of simulation you are performing. By
double clicking on transient block you can adjust the time range to the range of interest.
Change the time range as shown in Figure 3.5.
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Figure 3.5

Transient simulation

To define the input and output variables for the transmission line you need to
label the wires as shown in Figure 3.4. Add label ip to the wire connected between the
and

TLIN
in the schematic by double clicking on the wire; enter the ip in the wire/pin

label dialog box, click on the wire to place label name ip. Close the wire/pin label dialog
box and then follow the same steps to label the wire between

and R2 as op. If you

want to change a label name then click on it and edit the label name. Save the file by
selecting

File>Save

Design

or

hit

Ctrl+S

in

the

Schematic

window

as

transmission line_reflections. Notice that ADS saves this file in the networks folder
under the refelection_board_prj folder. Now, we are ready to simulate. To do the
simulations select

Simulate> Simulate or hit F7. If simulation is successful then a bla

database window will open as shown in Figure 3.6.
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Figure 3.6

Database window for impedance model

The left pane of the database window provides several options: rectangular plots,
polar plots, smith chart plots, multiple plots, tables and equations. For our schematic we
are going to plot voltage at the input and output of the

(transmission line). Now, left

click the rectangular plot icon and left click in the middle of the database window. The
Plot Traces & Attributes window will pop up with a menu that you can add ip and op in
V. You can also measure the value at any time on the plot by placing markers, which is
selected by choosing Marker>New. Place it on the curve where you need to know the
value as shown in Figure 3.7.
Notice that the wave shape changes significantly as the rise time exceeds twice
the delay of the line i.e. the reflections from the source arrive before the transition from
one state to another is complete. In the curve we see delay at the output “op” from the
input “

ip,” voltage division the 150 fl source resistance and 50 0 Zo of transmission line,

effective open at load give reflection coefficient of 1, reflection coefficient at the source
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Figure 3.7

Transient simulation for ideal transmission line circuit

end which is [(Z]-Zo)/( Zi+Zo)], wave bounces back and forth until reaches steady
state at 2V.
ADS have many built-in tools. One of the popular tools is LineCalc. This tool is
used to calculate the impedance and dimensions for waveguides and microstrip lines. If
we want to open the LineCalc tool there must be a Schematic window open. LineCalc
tool is used in the
ideal transmission line (

transmission _line_refelctionsschematic, just to build and replace

TLIN)with microstrip line (). Open LineCalc by: selecting

tools>LineCalc>Start LineCalc in the Schematic window.
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Figure 3.8

LineCalc window

The parameters in LinCalc for the microstrip line are defined as follows: Er relative permittivity, Mur - relative permeability, H - height of the substrate, Hu - if the
design was covered by a metal box, this would be its height, T - conductor thickness,
cond - conductivity of the conductor, TanD - dielectric loss tangent, Rough - RMS
surface roughness of the dielectric, W - width of conductor, L - length of line, Z0 characteristic impedance of line, E E f f - effective electrical length, K Eff - effective
dielectric permittivity of the system, A_DB - total attenuation of the system.
Then change all the default values in the LineCalc according to the board you are
using as shown in Figure 3.8. You can set the physical parameters (W and L) and push
the Synthesize button to calculate the Zo (impedance) and E Eff (effective electrical
length). If you want to calculate the W (width) and the L (length) by specifying the Zo
and E_Eff then push the Analyze button. Replace the TLIN with the MLIN component as
shown in Figure 3.1 by selecting Tools>LinCalc>Place New synthesized Component in
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Figure 3.9

Simulated results for the microstrip line

the Schematic window. Notice that the MLIN component will be placed by left
clicking in the Schematic window with W and L values as calculated in the
LinCalc/untitled window along with the MSub component, which is placed
automatically as shown in Figure 3.1. Msub defines the microstrip substrate that’s being
used, given all the parameter values as mentioned while doing the calculations in the
LineCalc/untitled window. Now, simulate the schematic. The result for the schematic in
Figure 3.1 is shown in Figure 3.9. Notice that this is the same plot we got with TLIN.
There is minor exception ringing at front edge and capacitive rise. This reflects a
different simulation between the ideal transmission model and a more physical microstrip
model.

Measurement
Design validation is needed to prove that the design is accurate, no critical issues
are neglected and to verify whether the simulation results are correct they should be
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correlated with the measurements. Measurements are the link between simulations and
reality and help the designer to check and balance for a robust design. Typical
measurements are performed on a Network Analyzer.
A Network Analyzer is designed to test components in the rapidly expanding field
of RF and wireless communications. Imperfections exist in even the finest test equipment
and cause less than ideal measurement results. Some of the factors that contribute to
measurement errors are repeatable and predictable over time and temperature can be
removed, while others are random and cannot be removed. The basis of Network
Analyzer error correction is the measurement of known electrical standards, such as a
through, open circuit, short circuit, and precision load impedance. Component tests are
crucial for the smooth operation of wireless communication networks. This instrument is
a 2-port, 4 receiver S-parameters (also called scatter parameters) Vector Network
Analyzer. Network Analyzer is used to provide measurements to extremely high
frequencies (range of operation is 300 kHz to 6 GHz) in the S parameters and time
domain reflectrometry (TDR) measurements.
S parameters describe the performance of each port completely. S parameters
relate traveling wave (power) to a two ports reflection and transmission behavior. Now,
look at the S parameters coefficients individually from equations (3.1) through (3.4),
interpretation in voltage are as follows:
(3.1)

(3.2)

(3.3)

( 3 .4 )
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Su is the reflection coefficient at port 1 when port 2 is impedance matched. S2l is the
transmission coefficient, defined as the output voltage at port 1 over the input voltage at
port 2 when both ports are terminated by Z0. S22 is the reflection coefficient at port 2
when port 1 is impedance matched.

Sn is the transmission coefficient, defined as the

output voltage at port 2 over the input voltage at port 1.
The magnitude of 5,, and S22 is always less than 1. If not, it represents negative
ohmic values. S2l and <Sj2 can exceed the value of 1 in case of active amplification. If
S2\ and Sl2 are negative, there is a phase shift. When S2t and Su are equal to 1 unity
gains signal transmission in the Z0 environment and if they are greater than 1 i.e. the
input signal is amplified in the Z0 environment. S parameters will play an important role
in microwave designs as they are easier to measure and to work with at higher
frequencies than any other kind of two port parameters.
For digital systems measuring the frequency domain S parameters may not be all
that useful. Time domain measurements are more useful. One such type of time domain
measurement is time domain reflectrometry (TDR).
TDR measurements are used to extract impedance, velocity and mutual and self
transmission line electric parameters. TDR measures the reflections as a function of time
of an injected signal by an unknown device. This allows the determination of location
and magnitude of all impedance discontinuities along a transmission line. This technique
also allows for easily de-embedding the influence of test fixture from the measurement.
Frequently Network Analyzers come equipped with internal processing capable of
translating S parameter measurements into TDR measurements.
Our Network Analyzer () has two TDR modes, low pass step and low pass
impulse. The Network Analyzer is setup for time domain low pass step mode, by
pressing:
System->Transform menu->Low pass step, Transform On
(The Network Analyzer in time domain low pass impulse mode then press
System->Transform menu->Low pass impulse, Transform On)
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In order to make a measurement first select the mode then setup the time range by
pressing the Start and Stop buttons. Now, calibrate full two port network parameters
such as reflection coefficient, transmission coefficient using the CAL knob. Also use the
smith chart to check the matching of the input and the output. Calibration is done by
pressing:
Cal->Calibration Menu->Sn 1-port (followed instructions)

3.2. Experiments
Typical issues effecting the signal integrity of digital systems include parameters
associated

with

the

PCB

(inherent

parameters),

reflections

from

impedance

discontinuities, and signal transmission and coupling to adjacent traces. We have
designed test boards to illustrate these issues. Experiments were implemented on the test
boards and the measurements were compared with simulations in ADS. The experiments
are described below.

3.2.1. Inherent parameters:
This experiment analyzes the effects of inherent parameters i.e. velocity of
propagation and impedance of transmission line on a high speed digital board, which both
depend on the dielectric constant (er) of the board.
In order to measure er we designed a simple microstrip with characteristic
impedance of 50 12 assuming a nominal dielectric constant er of 4.2, a board thickness of
62 mils and at frequency 800 MHz. FR4, a common board material, can have a range of
er = 3.9 - 4.3 [Leys, 2004], Using these values we calculated that the microstrip required
a width of 120.94 mil.. For the designed board we used a length 2244.1 mil and width
120.94 mil on a FR4 material board. The board is as shown in Figure 3.10. This board
has 4 identical microstrips terminated in 4 different loads, open, short, 100 12, and 25 12.
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Figure 3.10 Open circuit, short circuit, 100 ft and 25 ft load
transmission line
To calculate er we consider equation (3.5):

r

where c is the speed of light and Vp is velocity of propagation.
From measurement the 2 way length (

) of the open circuited transmission line

is 0.114±0.0005 m; that is measured using micrometer. To measure the dielectric
constant of the board we need to get the delay through the adapter and time taken by the
microstrip line. These values are extracted from the Network Analyzer. Setup the
Network Analyzer in time domain low pass impulse mode, select the analyzer time range
from 0 to 2 ns and calibrate the analyzer.
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Now, by adding an adapter to the N-type SMA, we measure the time at which the
signal is at its peak, which gives the time delay through the adapter of 190±5 ps. Then
connect the transmission line and adapter open and measure the time at which the signal
is at its maximum which is measured to be 970±5 ps. Assume that both measurements
have a resolution of + or - 5 ps and 3 significant digits.
velocity of propagation

To calculate er of the board

Vpis given by equation (3.6):

* > V(Tline - * adapter
/
)'

( 3

'6 )

where 2*L is the two way length of the transmission line, 7/,„e is the 2 way delay through
the transmission line plus adaptor, Tadapter is the 2 way delay through the adapter.
We determine the range of Vp by taking the minimum length (0.1135 m) divided
by the maximum time delay (975 ps) minus the minimum time delay (185 ps) through
the adapter to calculate minimum Tp (1.436709 m/s). The maximum Vp (1.487013 m/s) is
given by the maximum length (0.1145 m), minimum time (965 ps) and maximum time
through adapter (195 ps).
As substituting the range of Vp into equation (3.5) we obtain the range of €r. The
minimum Vp (1.436709 m/s) to calculate maximum er (4.070174). The maximum Vp
(1.487013 m/s) is used to calculate minimum er (4.360286). The measured er is
4.22±0.16. From the manufacturer web site er varies from 3.9 to 4.3 [Leys, 2004], By
looking at the quote €r and the actual value of er we can observe that they both are in good
agreement.
We used the ADS LineCal tool to determine variations in the characteristic
impedance for a given width and variations in width for a given characteristic impedance
for variations in dielectric constant. Plug. LineCal tool considers only 3 significant digits
and Mur - 1, H - 62, Hu - 3.9e+34, T - 1.4, cond - 5.813e7, TanD - 0.001, Rough - 0,
Freq is 800 MHz. The results of these calculations are shown in Table 3.2. We can see
that the uncertainty in dielectric constant leads to a ±2 % in characteristic impedance for
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a given width and a ±2.5% uncertainty in width for a given characteristic impedance for a
given width.

Table 3.2 Table for showing varying of Zo, E_Eff, W and L with er
Set W 120.94 mil

Set Zo is 50 Ohm

(r

Z0(12)

W(mil)

4.07

50.70

123.79

4.20

50.00

120.94

4.22

49.89

120.51

4.21

49.92

120.62

4.36

49.17

117.59

3.2.2.
3.2.3. Reflections on transmission line

This experiment evaluates the reflections on the transmission line. A signal is
reflected when there is any discontinuity at the end of the transmission line. The
implementation consists of different cases of a transmission line.
The implementation consists of a microstrip of 50 12 impedance with length
2244.1 mil and width 120.94 mil on a FR4 material board with dielectric constant er of
4.2, 62 mil thickness and at frequency 800 MHz i.e. transmission line is exactly matched
to Network Analyzer port and terminate in a resistive loads Zdc of 25.3 12 and 99.81 12
on two different boards as shown in Figure 3.10. The equation we consider for
measurement of load resistance is given by equation (3.7):

r totai = r , + T J 2T2u ( t- T )

(3.7)

where T| is partial reflection coefficient of a wave incident on a load, from the
transmission line. T2 is a partial reflection coefficient of a wave incident on a
transmission line, from a load. J, is partial transmission coefficient of a wave incident
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from the transmission line, from a load. T2 is a partial transmission coefficient of a wave
incident on a load, from the transmission line
To measure the resistive loads of the board we need to get the delay through the
adapter and time taken by the microstrip line since we must subtract the time taken
through the adapter from the microstrip line. These values are extracted from the
Network Analyzer. Setup the Network Analyzer in time domain low pass impulse mode,
select the analyzer time range from 0 s to 2 ns and calibrate the analyzer.
Then connect the transmission line terminated in a DC resistive load of 25.3 ft
and 99.81 ft and measure the reflection coefficients. Assume that both measurements
have a resolution of + or - 5 ps and 3 significant digits. The measurement plots for both
25.3 ft and 99.81 ft resistive loads are shown in Figure 3.11 and Figure 3.12:

Figure 3.11 Measurement plot for 25.3 ft resistive load

92

Figure 3.12 Measurement plot for 99.8112 resistive load

From the plots notice that Mrk 1 is placed to measure the reflection coefficient of
a wave incident on a load, from the transmission line and Mrk 2 is placed to measure the
reflection coefficient of a wave incident on a transmission line, from a load. The
calculations to derive load impedances are shown below:

r , . . , = r 1+ r , r !r 2« ( / - n

(3.8)

For a DC resistive load of 25.3 12 the calculations are as follows. The
characteristic impedance Zo of Network Analyzer is 50 12. When t < T, then r totai and
impedance Zi are given by equations (3.9) and (3.10) respectively,

Ttotal = r! =-0.0385

(3.9)

Z, = Z0[(l + T,) /(I - T,) = 46.2927312

(3.10)
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When t > T, then using equations (3.11), (3.12), (3.13) and (3.14) allow us to
solve for load impedance R li given by equation (3.15),

r tofa, = r 1+ 772r 2 = - 0 . 3 4 9

(3.11)

Tx= (2 * Z,) /(Z, + Z0) = -0.9615

(3.12)

=(2 *Z0)/(Z ,+ Z 0) = 1.0385

(3.13)

T2

r 2 = F'otai " T,) /

(3.14)

= -0.31096Q

(3.15)

= Z,[(l + r 2) / ( l - r 2) = 24.33139 Q
% diff = 100 * (

ZD
- R u ) / ZDC = 3.828%
C

(3.16)

For a DC resistive load of 99.81 ft the calculations are as follows. The
characteristic impedance Zo of the transmission line is 50 f t . When t < T, then r totai and
impedance Zi are given by equations (3.17) and (3.18) respectively,

r « « = r , = -0.0355

(3.17)

Z i — z 0 i+ r , = 46.5717

(3.18)

i-r,

When t > T, then using equations (3.19), (3.20), (3.21) and (3.22) allow us to
solve for load impedance R li given by equation (3.23),

r toto/= r ,+ 7 ;r 2r 2 =0.326
Tt = (

(3.19)
*Z,) /(Z, + Z0) = -0.9645(3.20)

2

T2= (2* Z0)/(Z ,+ Z 0) = 1.0355
r2

=(Tloml- T x)IT xT2= 0.361956Q

R lx =Z,[(l + r 2) / ( l - r 2) = 99.41107Q

(3.22)
(3.23)
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% diff = 100*(

Z -C
DR lx)

I

= 3.29%

(3.24)

On comparing RLi with the Zdc for both resistive loads, notice that both are in
good agreement.
Now, to simulate boards, plug in the values calculated above in ADS simulation
then the schematic circuit for both DC resistive loads of 24.3 ft and 99.4 ft are shown in
the Figure 3.13 and Figure 3.14.
-iglxt

Figure 3.13 Schematic for calculating DC resistive loads of 25.3 ft
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Figure 3.14 Reflection coefficient G vs time in nsec for DC resistive loads of 25.3
it

Figure 3.15 Schematic for calculating DC resistive loads of 99.4 it
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Figure 3.16 Reflection coefficient G vs time in nsec for DC resistive loads of
99.4 0

In schematic window, notice that the microstrip line width and length is
135.458661 mil and 2848.452756 mil respectively, which are calculated in LineCalc by
placing dielectric constant 4.22 from calculations of er, Mur - 1, H - 62, Hu - 3.9e+34, T
- 1.4, cond - 5.813e7, TanD - 0.001, Rough - 0, Freq is 800 MHz. The resistance at the
source Ri is 50 0 and resistance at the load R2 is 25.3 0 and 99.4 0 with a step input of 2
V. Simulate the circuit by placing the transient block.
Plot the reflection coefficient G Vs time in nsec as shown in Figure 3.14 and
Figure 3.16. We know that the transmission coefficient T is G + 1. So from plot we can
see the Gi and G2 for resistive load of 25.3 fl are -0.038 and -0.349 and for 99.4

are -

0.035 and 0.326.
On comparing the values of Gi and G 2 from the Network Analyzer and
simulations, notice that they are in good agreement with each other.
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Discontinuities
This section deals with the microstrip lines to experiment a width change i.e.
steps, bends and T- junctions. In these cases fringing field effects, leads to equivalent
capacitive elements. For the microstrip step circuit as shown in Figure 3.17 due to
comers, yields a dominant series capacitance effect and edge current disturbances occur,
which give rise to equivalent inductances. T- Junctions occur in a wide variety of
microstrip circuits (see Figure 3.20). The inductance and capacitance are included for
identical reasons to those described for step circuit.

Figure 3.17 Picture for step discontinuity
From the plot, notice that the Mrk 1 (-0.10254) is placed to measure the reflection
coefficient of a wave incident on a transmission line with width and length, from the
SMA connector and Mrk 2 (-0.348) is placed to measure the reflection coefficient of a
wave incident on a transmission line, from a transmission line of width and length. From
the calculations similar to those used to calculate the resistive loads 25.3 ft and 99.81 f t .
The plot for simulating the step discontinuity is shown in Figure 3.19.
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Figure 3.18 Plot for step discontinuity from measurements
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Figure 3.19 Plot for step discontinuity from simulations

Figure 3.20 Picture for T- junction
Reflection Coefficient

0.65051
0.9138

0.36471

Figure 3.21 Plot for T - junction from measurements

Figure 3.22 Plot for T - junction from simulated
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Solutions to eliminate reflections:

We have seen different types of reflections on the transmission line, which have a
compelling negative impact on the performance of a digital system. In order to avoid the
degrading performance of the digital system the reflections must be minimized or in other
words, they should reach a steady state. In order to achieve this the following methods
are suggested:
> By decreasing the frequency of the system, we can observe that the reflections on
the transmission line reach a steady state before another signal is driven onto the
line.
> We can also bring the reflections to a steady state in a shorter time by decreasing
the length of the PCB traces.
> By terminating the transmission line with impedance, equal to the characteristic
impedance of the line on either side.
The first two methods have their own limitations. Firstly, we cannot decrease
the operating frequency of a high speed digital system as they are operated at high
frequencies. Secondly, we cannot decrease the length of the PCB traces either, because
that requires a PCB board with a greater number of layers that increases the cost of the
board. So the best way to eliminate reflections is by matching the impedance of the
transmission line with its characteristic impedance. There are many ways to implement
matching termination, which includes matching the characteristic impedance of the
transmission line at the source end of the transmission line and matching the
characteristic impedance at the load i.e. at the far end of the transmission line.
3.2.4. Transmission

In this section we explain the effective propagation delay and the signal integrity.
Crosstalk is the coupling of energy from one line to another. This occurs when the
electromagnetic fields from different structures interact. Crosstalk will occur more in
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digital designs involved in moderate to high speed digital systems. The problem of
crosstalk noise can be considerable due to the increase in the demand from the consumer
for physically smaller and faster products. Crosstalk will affect the performance of the
transmission lines in the bus by changing the effective characteristic impedance and
propagation delay that will adversely affect the system - level timings and integrity of the
signal. Crosstalk will also produce noise into the other lines, which degrade the signal
integrity and reduce noise margins. These effects can be compensated by increasing the
line to line spacing, minimizing the parallel run lengths between signals and reducing the
edge rates. In practice, we are going to see that significant crosstalk can exist when the
lines are separated with different spacing and by varying length between signals. In the
next section we have introduced the circuit boards that show these effects in crosstalk
using ADS software and compared them with the measured values using Network
Analyzer.

Table 3.3 Boards used and their specifications
Board

Space

Length (mil)

Width (mil)

1

20

2304

121

2

48

2304

121

3

48

1392

121

These boards are used to measure near and far end crosstalk voltages and the
associated rise time. The measured values have been compared against the simulated
values. The graphical representation of the crosstalk measurements are shown below:
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Figure 3.23 Graphical representation of crosstalk noise

The boards under scrutiny have the set up shown in Figure 3.23 with varying
length between the signals and line to line spacing. Boards are set up in ADS and the
artwork is generated for each board and was etched for comparing the performance of
each board using Network Analyzer and ADS simulations. First, measure the rise time of
the each circuit board when all other ports are terminating by the resistor R = 50.207 Q
(since 50 Q resistors are not available) to avoid the reflections as the characteristic
impedance of the transmission line ZO = 50 Q; and connect port 1 of Network Analyzer
at the input and give a step input, measure the output waveform at port 2 of Network
Analyzer. From the waveform at V (output) we can measure the rise time by terminating
all other ports with the resistors R including port 1 and port 2.
Rise time (Tr) is defined as the time taken by the waveform to go from 0.1 to 0.9
of its final value. Rise time is calculated by taking the difference in time at 0.1 and 0.9 of
final value of waveform [Nise, 2000]. Rise time gives information about the speed of the
response. This information helps in determining the speed and the nature of the response,
whether it will degrade the performance of the system or not. These rising and falling
edges on the driver line will induce crosstalk into the victim line, if the rise time is much
smaller than the delay of the line.
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After calculating the rise time at V (output), connect port 2 at V (near) to measure
the voltage at the near end of the circuit board and terminating all other ports in resistor
R. Near end crosstalk is defined as the crosstalk measured on the victim line at the end
closer to the driver. A portion of crosstalk induced on the victim line will travel back to
the near end so it is also called the backward crosstalk. The near end crosstalk will have
duration equal to twice the time delay (electrical delay of the transmission line) and the
peak of the pulse is measured to be the near end crosstalk (V(near)). By using equation
(3.33) V(near) is calculated [Hall

etal., 2000]:

L

(3.33)

C

where Cmand C are the mutual and self capacitance respectively. Lm and L are the mutual
and self inductance respectively. V(input) is the input voltage measured at V(input)
shown in Figure 3.23. From equation (3.33) we can illustrate that the near end crosstalk
will depend on the amount of coupling.
Far end crosstalk is estimated by connecting port 2 at V (far) of the circuit board
by terminating all other ports in resistor R. Far end crosstalk is defined as the crosstalk
measured on the victim line farthest from the driver. A portion of crosstalk induced on
the victim line will travel towards the far end so it is also called forward crosstalk. The
signal reaches the far end at a time equal to the time delay (electrical length of the
transmission line). The duration of the pulse at the far end will be equal to rise time. The
peak of the pulse is measured to be the far end crosstalk ( V(far)). By using equation
(3.34)

(far)si calculated [Hall etal., 2000]:
V

. .. , ,
V(input)Xy[LC h .L
V(far) = ---2T
L

( 3 .3 4 )

C
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where X is the line length. From equation (3.34) we illustrate that the far end crosstalk
depends on the amount of coupling, line length and rise time.

Table 3.4 Crosstalk calculations
% difference

Simulations

Measurements

V(near)

V(far)

-0.03805

15.37

1.862

0.07784

-0.03405

3.997

0.959

0.06224

-0.02043

8.22

-0.25

Tr

V(near)

V(far)

Tr

V(near)

V(far)

(ps)

(V)

(V)

(ps)

(V)

(V)

1

367

0.14924

-0.038772

370

0.1263

2

355

0.081081

-0.03438

350.1

3

349

0.067817

-0.020379

340

Board

The boards are shown in Figure 3.24 and the plots from measurements are taken
at V (output), V (near) and V (far) as shown in Figure 3.23 for each board are shown in
Figure 3.25, Figure 3.27 and Figure 3.29 respectively. In Figure 3.26, Figure 3.28 and
Figure 3.30 plots are taken from ADS simulations for each board respectively. From the
plots and Table 2 of near end crosstalk for board 1 and board 2, notice that with the
increase in spacing the coupling between the signals decreases, which agrees with
equation (3.4). We can also perceive that the near end crosstalk is independent of the
input rise time when rise time is shorter than the delay of the line, which is satisfied by
both board 1 and 2. For board 3 we can observe that the rise time is longer when
compared to the delay of the line so near end crosstalk is dependent on the rise time.
From the plots and Table 2 of far end crosstalk we can notice that the far end
crosstalk is dependent on the rise time and the length of the line, which agrees with
equation (3.5). If we compare board 2 and board 3 there is decrease in the line length so
the far end crosstalk decreases. Finally we can conclude from all these observations that
the simulated and measured values are in good agreement.

I
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(a)

(b)

(c)

Figure 3.24 Picture of all the three boards used to measure the crosstalk
(a) Board 1

(b) Board 2

(a) Board 3

(b)

(c)
Figure 3.25 Plots from measurements of board 1
(a) V (output)

(b) V (near)

(c) V (far)
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(a) V (output)

(b) V(near)

(c) V

(f

0.89908

0.096892

Time (ns)

Reflection Coefficient

0.081081

Reflection Coefficient

■0.03438
2.2

2.4

2.6

2.8

3

3.2

3.4

36

3.8

4

4.2

4.4

46

Time (ns)

(c)
Figure 3.27 Plots from measurements of board 2
(a) V (output)

(b) V (near)

(c) V (far)

4.8

5
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Figure 3.28 Plots from simulations of board 2
(a) V (output)

(b) V (near)

(c) V

Reflection Coefficient

0.89905

0.097382

(a)

0.067817

2

2.2

2.4

26

2.8

3

3.2

3.4

3.6

3.8

4

4.2

4.4

46

48

5

2.8

3

3.2

3.4

36

38

4

4 2

44

4 6

4.8

5

Time (hs)

■0.020379
12

1.4

1.6

1.8

2

2.2

2.4

2.6

Time (ns)

(c)
Figure 3.29 Plots from measurements of board 3
(a) V (output)

(b) V (near)

(c) V (far)
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(C)
Figure 3.30 Plots from simulations of board 3
(a) V (output)

(b) V (near)

(c) V (far)
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Till now we have seen the general cases assuming that the termination resistors
are matched to the transmission line characteristic impedance. Now let’s see some special
cases by taking board 3.
In case 1, connect port 1 and port 2 of Network Analyzer at input by giving step
input waveform and V (near) respectively, leaving V (far) open and terminating the other
port by resistor R. The measured and simulated plots for case 1 are shown in Figure 3.31.
We can observe from the plots that, at the near end of the transmission line, the input
signal does not undergo any phase change, but the magnitude of the input signal that
reaches the near end is reduced by the amount of spacing between the line and the second
dip is due to the reflections from the opening at the far end.

(a)

Figure 3.31 Measured and simulated plots for case 1
(a) Measured

(b) Simulated
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In case 2 connect port 1 and port 2 of Network Analyzer at input by giving step
input waveform and V (far) respectively, leaving V (near) open and terminating the other
port by resistor R. The measured and simulated plots for case 2 are shown in Figure 3.32.
We can observe from the plots that at the far end of the transmission line, the input signal
undergoes a phase change, which is due to the length of the line the wave has to travel.
The reduction in the magnitude of the signal is obvious. There is a peak due to the
reflections caused by the opening at the near end.

(a)

Figure 3.32 Measured and simulated plots for case 2
(a) Measured

(b) Simulated
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Serpentine Traces
Here we are going to study the traces that have serpentine patterns on the PCB,
since it is difficult for the designer to route all the traces on the board in a straight line.
Serpentine traces will effect propagation delay and signal integrity. To understand
serpentine traces, we will see two different cases.
In case 1 take a serpentine trace that has enough space between parallel sections,
which eliminate crosstalk effects that allow the signal to propagate down in the same
manner as it does in a straight line.
In case 2 a serpentine trace is built with closer spacing between parallel sections,
so a portion of the signal will propagate in a path that is perpendicular to the serpentine
passing through mutual inductance and capacitance, which results in getting a portion of
the signal at the output early. This kind of behavior will affect the signal integrity and the
delay.
The boards for case 1 and case 2 are shown in Figure 3.33. The measured and
simulated plots for case 1 and case 2 are shown in Figure 3.34 and Figure 3.35
respectively. From the plots of both cases we can observe that with the increase in
spacing between the lines i.e. from 30 mils to 500 mils spacing in case 1 and case 2,
notice that the waveform is approaching the straight line case. In case 2 there is an
increase in length of the coupling sections and decrease in the spacing between the
parallel sections when compared to case 1, which results in a significant increase in
crosstalk effects. Subsequently, the signal in case 1 will arrive faster when compared to
case 2 signal at the output. We can notice that all these factors are in good agreement in
measured as well as in simulated values for both cases.
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(b)
Figure 3.33 Picture of board
(a) Case 1

(b) Case 2
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Figure 3.34 Measured and simulated plots for case 1
(a) Measured plot

(b) Simulated plot
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Solution to minimize the crosstalk:
Some of the guide lines to minimize the cross talk in most of the circuit boards are listed
as follows:

> Increase the spacing between the lines such that routing restrictions will not be
violated.
>

Design the transmission line so that the conductor is as close to the ground plane
as possible (i.e., minimize H) while achieving the target impedance of the design.
This will couple the transmission line tightly to the ground plane and less to
adjacent signals.

> Use differential routing techniques for critical nets, such as the system clock if
system design allows.
> If there is significant coupling between signals on different layers, route them
orthogonal to each other.
> If possible, route the signals on a stripline layer or as an embedded microstrip to
eliminate velocity variations.
> Minimize parallel run length between signals. Route with short parallel sections
and minimize long coupled sections between nets.
> Place the components on the board to minimize congestion of traces.
> Use slower edge rates. This, however, should be done with extreme caution.
There are several negative consequences associated with using slow edge rates
Conclusions
In all these experiments we analyzed some of the high speed issues, which
include timing analysis, reflections and crosstalk. Now, we need a tool to implement
these issues on a PCB. Cadence® SPECCTRAQuest™ tool is used as a board level
simulator that is explained briefly in chapter 4.
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4. CADENCE® SPECCTRAQUEST™
4.1. Introduction
The Cadence® SPECCTRAQuest™ SI Expert tool is used as a board level
simulator and uses the same database that is used in the layout of the board in Allegro®.
This reduces both the timing and risk required in new high speed designs. Cadence®
SPECCTRAQuest™ SI Expert includes tools like Cadence® SPECCTRAQuest™,
Constraint Manager and SQ Signal Explorer. By using the design flow shown in Figure
4.1, which consists of all the tools for a high speed PCB design, a designer can eliminate
the high speed issues that include timing analysis, reflections, crosstalk and losses in high
speed design.

Figure 4.1

Design flow for high speed PCB design [Cadence®, 2003b]

The role of each tool in the design flow for a high speed PCB design is explained.
The Concept HDL tool is used in the schematic entry, which will translate the logical
design entered into a physical design set for layout in Allegro®. The Cadence®
SPECCTRAQuest™ tool is used to perform the simulations on the design and it creates
constraints that help in placing and routing the components in the design. Constraint
Manager plays a significant role in the board design; it is used to setup constraints such as
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bounds for reflections, crosstalk, timing, etch length, impedance etc., for the design
during the analysis of the nets. It does all this through a spreadsheet, which can be
launched at any point to view the high speed design issues. Constraint Manager allows
the designer to graphically create, edit, analyze and define a physical interconnect. The
graphical environment for interconnect is shown using the SQ Signal Explorer tool. The
designer solves the problems that arise due to the high-speed interconnections by using
Cadence® SPECCTRAQuest™ along with SQ Signal Explorer by extracting critical nets
in the design. The SQ Signal Explorer tool is used to extract topology and fix the
following problems:
> Setting the board stack-up including trace geometries.
> Evaluating the losses due to skin effect and dielectric loss.
> Giving design rules: on the allowable trace length for the high-speed data/clock,
on spacing to the control crosstalk, on the termination selection in types and
values, and on the maximal length mis-match with all differential pairs.
Constraint Manager, SQ Signal Explorer and Cadence® SPECCTRAQuest™ tools can
be used back and forth at any point in the design. This will allow the designer to optimize
the high speed effects without increasing the impact on other high speed issues and the
chance of error.
This chapter discusses the high speed design procedure using Cadence® tools and
implements them on an example board signal2.brd (integrity board), which is part of a
larger radar controller design. The logical design of the board has already been entered by
the Concept HDL tool as shown in Figure 4.2. Concept HDL also generates BOM
reports, checked electrical rules, netlist reports and physically exports the design. This
translates the logical design entered in Concept HDL into a physical design that is set for
doing layout using the Allegro® tool. The following section discusses the procedure to
be followed after completing layout in Allegro® and the difficulties that may arise when
using the Cadence® SPECCTRAQuest™ SI Expert tool on high speed designs. It also
provides solutions [Cadence®, 2004;

adenc®
C2003e;
,
Hall et al., 2000].

Figure 4.2

Logical design of the signal2.brd (integrity board)
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4.2. Basic flowchart for high speed design
The Cadence® SPECCTRAQuest™ SI Expert tool is used in executing
simulations on high speed digital designs and helps in modeling PCBs, system level
cables and connectors. Simulations are done to make sure the design will perform its
intended functions over the intended range of conditions. This includes component value
accuracies, the power supply voltage range, the timing range, etc. The Cadence®
SPECCTRAQuest™ SI Expert tool is built to perform tests quickly, rigorously, and
completely. It will also discover the defects that can be corrected in the simulation
models with ease and simulations can be rerun before fabricating the design. The basic
flowchart for high speed design is illustrated in Figure 4.3. The schematic capture using
Concept HDL (see Figure 4.2) and importing the schematic from Concept HDL into
Allegro/ SPECCTRAQuest are addressed in chapter 2. You can switch from Allegro®
(PCB Design Expert) to Cadence® SPECCTRAQuest™ (SPECCTRAQuest SI Expert)
by choosing File>Change Editor... Now, you will implement the flowchart on the
signal2.brd board that is a part of the integrity board. Here your goal is to simulate the
signal2.brd board by following the steps discussed in the flowchart:

123

Figure 4.3 Cadence® SPECCTRAQuest™ flowchart for high speed designs
[Cadence®, 2004]
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4.2.1. Board setup using database setup advisor
Before setting up the board, open the board file in Allegro/ SPECCTRAQuest
by selecting start >programs> Cadence PSD 15.1> Allegro/SPECCTRAQuest
Double click on the signal2.brd to open the file in the PCB design Expert or
SPECCTRAQuest SI Expert window.
Setup the board outline by using the board wizard as discussed in chapter 2
(“Basic Design and Fabrication”). Then place the components by importing the parts
from the schematic and place the components inside the board. If you want to do the
simulations on the board, which is already designed using the Cadence® Allegro® tool,
open that layout file in the SPECCTRAQuest SI Expert window. To provide the correct
board database to analyze the design with PCB Design Expert or Cadence
SPECCTRAQuest SI Expert tools and SQ Signal Explorer tool, Database Setup Advisor
will assist.
Database Setup Advisor is very useful in layout; it will help in extracting any net
into the SQ Signal Explorer for analysis. Database Setup Advisor will help in setting up
the layout cross-section, CLASS, PINUSE and DC Net properties, devices and SI
Models, and SI Audit. Database Setup Advisor, shown in Figure 4.4, is invoked from the
PCB Design Expert/SPECCTRAQuest SI Expert window by selecting Tools>Setup
Advisor...
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Figure 4.4

Database setup advisor

By clicking the Next button in the Database Setup Advisor, you will be assisted
in defining the cross-section i.e. in editing: the number of layers, material for the layers,
thickness of the board, dielectric constants, and conductivity for each layer in the board
as shown in Figure 4.5.
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Figure 4.5

Database setup advisor - cross section

After editing the cross-section of the board you can assign DC nets for the design
using Database Setup Advisor by clicking the

button.

To edit the DC nets for the design, select the Identify DC Nets button. Then, the
Identify DC Nets dialog box will pop up as shown in Figure 4.6.
Next, as shown in Figure 4.7, you can also define the connectors and discrete
parts of the design in device setup.
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Figure 4.6

Figure 4.7

Database setup advisor - DC nets

Database setup advisor - device setup
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Figure 4.8

Database setup advisor - SI models

You can also assign simulation models for all the devices in the design using the
SI model assignment. This is done by selecting the

button and clicking the SI Model

Assignment button in the window as shown in Figure 4.8.
Create models for all the 2-pin components automatically by clicking Auto Setup
and other components will find the models first in the existing library. If there are no
models found, create an IBIS model for the part by using the Create Model button; this
will be discussed later in this chapter.
After defining device models for all the components in the design, setup the SI
audit. This will check whether the selected net has the required models shown in Figure
4.9. It also generates the report for the net.
After completing the SI audit, click Finish to complete the Database Setup
Advisor Wizard. You can also go back and forth by selecting Next and Back while going
through this setup process.
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Figure 4.9

Database setup advisor - SI audit

After the board is setup, components should be placed inside the outline to
perform the simulation on the board. Mechanical elements such as those used to draw the
outline, route keepin and keepout area for the board, are created in a similar manner as
was done in Allegro® by using the board wizard. Refer chapter 2 for details.

4.2.2. Component placement and IBIS models
In order to perform simulations in SPECCTRAQuest SI Expert the components
need to be placed and assigned an IBIS model. The components are placed inside the
outline. Placement of the components should be predetermined. The ratsnest lines should
be displayed as it represents the connection existing before routing, as shown in Figure
4.10.
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Figure 4.10 Board setup for simulation
4.2.3.
The first step for implementing a simulation is to set the IBIS (Input/Output
Buffer Information Specification) models to all the parts in the design to perform
simulations. IBIS models are the detailed information of components such as input
section, output section, I-V characteristic information for ground clamp and power clamp,
die capacitance, reference temperature and also define the I-V curves for pullup,
pulldown, rise wave and fall wave and the characteristics of the package (i.e. the values
of the pin such as resistance, capacitance and inductance) depending upon the device
whether it is a input pin or output pin of the device. These files are written in ASCII
format. IBIS models can be assigned in the following ways:

> By getting the existing IBIS models for the components.
> Asking the manufacturer of the part for the models.
> Creating IBIS models.
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Figure 4.11 Signal analysis library browser

The foremost thing to do in finding the IBIS models is to search for the models in
the IBIS libraries of the manufacturer site or do a web search. Browse the existing models
in the Cadence® library to find the IBIS models from the Cadence® libraries.
If you go from the SQ SPECCTRAQuest Expert window, open the design
layout ( signa.l2.brd.) by selecting

Analyze>SI/EMI Sim>Library.

You can go directly to the IBIS models by opening the desired net in the
Schematic/Physical

SQ

Signal

Explorer

(C6.Top)

window

and

selecting

Analyze>Library, which opens the Signal Analysis Library Browser dialog box.
If you still cannot find the models, get them from the manufacturer of the
components; if the models for the components are not found in their web site, contact the
manufacturer. You can also get the models in formats other than IBIS and translate those
files into Cadence.dml (device model library) files by clicking Translate in the Model
Browser dialog box. If you do not get the models for the components after going through
all the above steps, create the IBIS model.
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Creating a new IBIS model for the components should be the last choice, as you
need to collect the following information [Peters et al., 1994]:

> Empirical data for the device i.e. gather data by means of experiment or
observation.
> All the package parameters (values of the lead resistance, capacitance and
inductance).
> The input or output capacitance of the buffer.
> All the I-V characteristics for the power clamp and ground clamp.
> If the device is performing an output function, it requires the I-V characteristics
for pull up, pull down, rise wave and fall wave.

Simulations are also done using full wave electromagnetic simulator such as HFSS,
which is beyond the scope of this thesis.

4.2.4. Preroute and analyzing nets using SQ Signal Explorer
SQ Signal Explorer helps in setting the electrical and physical constraints
depending on the requirements. These constraints are then imported into the SQ
SPECCTRAQuest™ Expert for the final placement and routing of the nets. To start
simulations in SQ Signal Explorer, the crucial nets are extracted into the SQ Signal
Explorer either directly or from the SPECCTRAQuest window by selecting
Analyze> Probe.
Choose the desired net to be analyzed. For instance, take Co net as shown in
Figure 4.12; then the Signal Analysis window will be displayed. Click View Topology to
view the topology of the net selected in the SQ Signal Explorer Expert window.
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Figure 4.12 Signal analysis
You can also open the SQ Signal Explorer Expert window as shown in
Figure 4.13 through SPECCTRAQuest™ SI Expert from Constraint Manager by
selecting

Setup> ElectricalConstraint Spreadsheet. The Constraint Manager spreadsheet

is a list of all the nets on the board. Choose the net you want to analyze using the SQ
Signal Explorer tool.
Before extracting nets into the SQ Signal Explorer, decide whether you want to
include the routed interconnections or use the actual route. At present you are analyzing
the prerouted nets. So, in the Constraint Manager menu, select Tools>Options in the
Options dialog box. Do not choose any options in the electrical CSet extractions so that
the nets will meet the timing and impedance parameters as mentioned in Analyze>SI/EMI
Sim>Preference in the SPECCTRAQuest window. In the SQ Signal Explorer window
there will be a spreadsheet at the bottom of the window that has different tabs to complete
the simulations. By selecting the Parameters tab you can view the circuit in the name
column that will expand by clicking the plus (+) sign next to it. You can see all the
circuit components under the name of the board (signal2).
You can change the impedance, propdelay, traceGeometry and velocity values by
clicking on the value. Set the Parameter window displayed as shown in Figure 4.14.
Next, in the Measurements tab are EMI, reflections, crosstalk and custom. In each
you have different options. You can do the simulations for any one of the options. In the
Results tab there will be results after simulating the circuit and in the command tab you
can enter the commands manually in the command console window. It will also display
the error and simulation messages.
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■Command Output Window
I last pick: 5497.50 4238.50
■last pick: 5515 00 4230.50
■Using SigNoise tun directory t):\Jnte^ity3dec\worklibUignalSphystcaruigxp. run'

Figure 4.13 SQ Signal Explorer and the Constraint Manager windows

Before implementing the simulations, choose the driver stimulus option, which is
invoked by clicking on the stimulus state of the driver. Then the IO Cell Stimulus Edit
window will pop up where you can specify the stimulus state of the driver for simulation.
If the stimulus is tristate then the simulation will abort as the stimulus state specifies the
type of input for simulation. Here in Figure 4.15, 74LS02 is the device model and
Z3766 0U T is the pin model of the part U1 (driver). It is similar to the receiver pin but
the stimulus state for the receiver will be tristate. Receiver Editor Window is invoked by
clicking on the stimulus state of the receiver, which allows you to specify the
measurement cycles or else it will take the measurement cycles from the Preference
dialog box.
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Figure 4.16 Analysis preferences

Figure 4.17 SigWave
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After setting all the parameters in the SQ Signal Explorer window according to
the design goal of the circuit, specify the simulation mode, measurement mode, pulse
stimulus, simulation parameters and EMI.
You can also select Analyze>Simulate in the SQ Signal Explorer menu. Then the
command console will pop up (see Figure 4.16). After completion of the simulations the
results are displayed in the Results tab and the waveforms at the driver and the receiver.
The internal buffer delays are displayed without the effects of the package, in the
Sigwave window as shown in Figure 4.17.
You can also export spreadsheet data results from SQ Signal Explorer by
choosing File>Export Spreadsheet in SQ Signal Explorer Expert Window

4.2.5. Performance factors and measurements
Time domain waveforms give the results for the simulation performed on the
design in the SigWave window. Some of the measures of Signal Integrity performance
for 74LS244, by taking the high level input voltage (VM) 2, low level input voltage
(VIL) 0.8, high level output voltage (VOH) 3.4 and low level output voltage (VOL) 0.4.
These values are taken from the datasheet. Some of the simulation measurements include:
Monotonic:
A monotonic signal is the one that does not have a reversal (overlap) between the
high and low thresholds. The measurement checks that the rising and falling edges of the
signal transition between the low and high threshold without changing direction. This is
pass or fail check.

Noise margin:
Noise margin (NM) is measured between the receiver input waveform and its
switching threshold. NM is given by the following equations [Leventhal, 2001].
NMhjgh V 0h Vjh

(4.1)

NMiow = Vj, - Vo,

(4.2)
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First Switch Delay:
First switch delay is measuring the delay that happens before an input rising
(falling) wave first crosses the Vn (or Vih) threshold [Leventhal, 2001].

Final settle delay:
Final settle delay is measuring the delay that happens until input rising (falling)
wave last crosses the Vih (Vji) threshold [Leventhal, 2001].

Overshoot high:
Signal ringing is due to the reflections on the waveform by the impedance
mismatch in the circuit. This reflections produce overshoot on both the high side and low
side of the waveform. Overshoot high is the maximum positive point of the rising
waveform [Cadence®, 2004].

Overshoot low:
Overshoot low is the maximum peak value of the falling waveform. Regardless of
where the low point of waveform is, the point where the waveform bottoms out is defined
as overshoot low [Cadence®, 2004].
4.2.6. Constraint Manager
Constraint Manager will play a significant role in the board design. Defining the
constraints for the design is very useful as they set the limitations. As shown in Figure
4.18 you can define constraints for a design during schematic entry or before placing the
components during layout. You can also define the constraints for the design during the
analysis of the nets in the SQ Signal Explorer from where you can export the constraints
into the Cadence® SPECCTRAQuest™ for doing the layout.
Constraint Manager contains two sets of electrical constraint sets and nets. In the
electric constraint set you can define the constraints for signal integrity so the designer
can define the bounds for reflections/edge distortions and xtalk/SNN and can also define
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Figure 4.18 Constraint Manager design flow
the constraints for timing (contains the switch/settle delays and setup/hold) worksheet,
routing, and custom measurements.
In the net set you can define the constraints for signal integrity, which can define
the limitations for electrical properties, reflection, edge distortions, estimated xtalk,
simulated xtalk, and SSN (simultaneous switching noise), timing, routing (wiring,
impedance, min/max propagation delays, total etch length, differential pair, relative
propagation delay), and custom measurements.
In the previous sections I discussed how to setup a board using the database setup
advisor. I then discussed how to extract the unrouted nets into the SQ Signal Explorer and
perform the simulations on the topology. This was followed by information about the
waveform measurements in the SigWave window i.e. how to correlate the results in the
results tab of the SQ Signal Explorer window to the waveforms in SigWave and measure
different parameters in the SigWave window like noise margin, overshootHigh,
overshootLow, switch delay, propagation delay and settle delay.
Now, this section will continue with how to assign constraints in SQ Signal
Explorer for the extracted topology and export that net into SQ SPECCTRAQuest™.
You will get the design requirements to enter in the constraints window through SQ
Signal Explorer from the design specifications and guidelines. Extract the unrouted Co net
of the design into the SQ Signal Explorer Expert window as shown in Figure 4.19. To
start the SQ Signal Explorer Expert window, select

in SQ

SPECCTRAQuest Expert. Then the Signal Analysis window opens. Select net to
analysis.
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Figure 4.19 Topology of Co net in SQ Signal Explorer window
Solution Space Analysis is used to route the high speed nets based on the
thorough analysis of the rules defined before routing. The constraints are determined to a
net from SQ Signal Explorer by selecting

in SQ Signal Explorer

Window, then define different rules between pins needed for the net by selecting any of
the following tabs: Max parallel, Wiring, User-Defined, Signal Integrity, Usage, SwitchSettle, Prop Delay, Impedance, Rel Prop Delay and Diff Pair from the Set Topology
Constraints form. After having satisfactory results for the net then save the topology.

4.2.7. Importing the topology template into the Constraint Manager

The first step to perform in the SPECCTRAQuest SI Expert window is to
update the constraint manager by opening the Constraint Manger spreadsheet,
selecting

Tools> Optionsform, selecting the Automatic Topology Update option and

clicking Ok. The topology application will be differed until you choose Tools> Update.

Display the net in the Constraint Manager by opening the Constraint Manager
Spreadsheet and clicking Net > Routing > min/max Propagation Delays and select
Objects > Filter. In the filter window the net on the right side and click Apply.
Now, while routing the net, the Dynamic Meter window shows up, which
displays the timing margin available and is displayed in green color indicates that it is
within the constraints specified. By following same procedure for all the nets in the board
are routed.

4.2.8. Check for DRC errors

When routing is completed for the whole board, check DRC errors by Choosing
Tools>Reports... the Reports dialog box appears. Select Design Rules Check and click
the Report button. Rectify all the errors that appear in the Design Rules Check Report
window either by new placement of the components or rerouting the nets. Repeat the
whole process till all the DRC errors are eliminated.

4.2.9. Post-routing analysis
After routing the nets in the board you can also analyze the nets and know how
the field solver is calculating in different parameters. This will be discussed briefly in the
next section.
4.2.9.I. Characteristic impedance
The closed formulas for calculating Z0 based on geometry usually do not include
frequency as a variable directly. Emperical equations for the characteristic impedance of
a microstrip (see equation (4.3)) can be found in many references, for example [Hall et
al., 2000]:
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where W is the trace width, T is the thickness of the copper, II is the dielectric thickness

£ris a dielectric constant. To have more accurate fo

over a ground plane, and

characteristic impedance see equation (4.4), where Ca is calculated from equation (4.5),
effective dielectric constant ee is calculated from equation (4.6) and F is calculated using
equation (4.7):

(4.4)

(4.5)

(4.6)

(4.7)

The formula used by the field solver in the SQ Signal Explorer for a single
transmission

line

by

extracting

the

transmission

line

from

the

Cadence®

SPECCTRAQuest™ will depend on whether the cut off frequency is zero or non-zero. If
the cut off frequency is zero then the characteristic impedance Zc calculated in the field
solver is given by equation (4.8) [Tan, 1994],
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This formula is used when you consider a lossless case. When the DC losses are
taken into consideration then the characteristic impedance Zc is calculated by using the
equation (4.9). [Tan, 1994].

(4.9)

If the cut off frequency is non-zero then the characteristic impedance is calculated
in the field solver by taking the same formula (4.9) for a lossless case. In the other case
the skin effect is taken into account to calculate the characteristic impedance, which is
given by formula (4.10) [Tan, 1994].

(4.10)

Now it is time to extract the routed net from Cadence® SPECCTRAQuest™ and
compare the characteristic impedance calculated using the above formulas and simulated
value using Field Solver in SQ Signal Explorer. As we learned to extract the net from the
Cadence® SPECCTRAQuest™ window into the SQ Signal Explorer window we will see
where Field Solver is calculating the characteristic impedance, capacitance, inductance,
linear resistance, velocity, admittance, delay values by varying the length, width,
thickness, etc. of the board and the transmission line.
By clicking on the length value, the view trace Model Param eters window will
pop up as shown in Figure 4.20.
By considering the linear resistance and capacitance values for the field solution
results, calculate the characteristic impedance by using the above formulas. The graph is
plotted by taking both the calculated and simulated characteristic impedance, which is
shown in Figure 4.21.
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Figure 4.20 View trace model param eters

Figure 4.21 Plot impedance vs width
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Formula 1, in the above plot, is calculated by using equations (4.4). Formula 2 in
the above plot calculated using equations (4.3).
On comparing the impedance varying with the width for the calculated and
simulated characteristic impedance we can observe that the simulations are calculated
using equations (4.8) and (4.9) are in good agreement with Formula 2. We can conclude
that the field solver in SQ Signal Explorer depend on whether the cut off frequency is
zero or non-zero.
4.2.9.2. Time delay

Time delay of the transmission line is the time taken by the signal to travel from
the driver to the receiver for the line. Time delay is calculated using equation (4.17),
[Hall et al., 2000],

Time delay =

(4.11)
c

where x is the length of the transmission line, in meters, sr is dielectric constant and c is
8

speed of the light in a vacuum (3*10 m/sec).
When the signal is traveling in a microstrip line then the electric fringes through the
dielectric material and air that will lowers the effective dielectric constant. Time delay
can also be calculated using equation (4.12) in which €e is calculated from equation (4.6)
and F is calculated using equation (4.7):

Time delays

(4.12)
c

Now simulate the trace by extracting the topology of the trace into the SQ Signal
Explorer window as shown in Figure 4.22 and modify the dielectric geometry as follows:
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Figure 4.22 Simulation results in SQ Signal Explorer window

Figure 4.23 Plot time delay vs dielectric constant

147
where Formula 1 in Figure 4.23 is plotted using equation (4.15). By comparing the
calculated time delay and simulated values we can see that the two curves are not close.
So we can consider that the delay of the transmission line depends on the dielectric
constant of the dielectric material, the line length, and the geometry of the transmission
line cross section. Then the effective dielectric constant for the microstrip is calculated
according to Formula 2 in Figure 4.23 is plotted using equations (4.16), (4.17) and (4.18).
On comparing the time delay varying with the dielectric constant for the
calculated and simulated time delay we can observe that the simulations are calculated
using the Formula 2 as they are in good agreement. We can conclude that the field solver
in SQ Signal Explorer considers the electric field fringes through the dielectric material
and the air in the case of a microstrip line and cross section geometry of the transmission
line is taken into account.
After analyzing the nets in the SQ Signal Explorer Expert window then check
for DRC errors and after finishing the board layout successfully, create manufacturing
outputs required for board fabrication. Manufacturing outputs (drill information and
silkscreen information) for the signal2.brd board are created exactly in the same way as
discussed in design example I in chapter 2.
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5. CONCLUSIONS AND FUTURE W ORK
5.1. Conclusions
The aim of Electrical Circuit Design Process and Fabrication is to meet the design
process for the generic and high speed digital PCB design. This thesis discussed the
design process of PCBs using Cadence® Software. In the process of PCB design, the
schematic capture, library management, layout and simulations of the board are
discussed. This dissertation provided detailed description of each process in the design
flow for the PCB, by taking design examples. Cadence® provided us the path to design
PCBs, but to rapidly prototype the design we need to implement simulations. This is
accomplished using ADS tool which is used for designing high frequency designs. ADS
tool is used for generating schematics, simulations setup, linear simulations, tuning and
viewing results of common circuit design. In this dissertation you have seen the example
interconnects developed to illustrate high speed issues in digital designs using ADS and
correlated simulated and measured values.
From all these experiments we analyzed some of the high speed issues, which
include timing analysis, reflections and crosstalk. Cadence® SPECCTRAQuest™ is used
as a simulating tool to implement these high speed issues on a PCB. The Cadence®
SPECCTRAQuest™ tool creates constraints that help in placing and routing the
components in the design. This dissertation discussed the high speed design procedure
using Cadence® SPECCTRAQuest™ tool and implemented them on an example board
signal2.brd (integrity board), which is part of a larger radar controller design.
While doing this project I assisted my research colleague Aditi Kolatkar in
generating schematics for radar controller board [

, 2004], I generated schematic

and layouts for the microwave and RF designs using ADS. I used Cadence® to design
MSS power supply board from part development, schematic capture to board layout to
manufacture of the board. Also, I helped in the design and layout of the sensor board.
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5.2. Future work
The Cadence® SPECCTRAQuest™ tool needs an extended understanding
regarding the simulations of a high speed board using Cadence® SPECCTRAQuest™
and SQ Signal Explorer that includes learning about creating IBIS models and should
understand more about SQ Signal Explorer and Constraint Manager. Also a thorough
understanding about HFSS (High-Frequency Structure Simulator) a 3D simulator is
needed; this is used to convert mechanical specifications of the lead width, lengths,
spacing and shape into electrical parameters. This data can then be transferred back to
Cadence® for signal integrity simulations. The physical layout tool in Cadence® called
APD (Advanced Package Design) that is used in mounting die(s) into package needs
exploration. APD models the package style and connects traces from bar die to the
package I/O pins. So by learning about the APD tool one can design die(s).
Cadence® is robust software that includes lot of tools, which addresses all
aspects of electronic designs. This thesis provides as a start up for designing PCB,
therefore we need to explore more about the tools in Cadence® software.

150
REFERENCES

Agilent, Advanced Design System 2003A, Documentation, Agilent technologies, 2003.

Berrie, J., Practical Printed Circuit Board Signal Integrity and EMC IEEE EMC Society,
Duxford, June 2005.

Cadence®, Concept HDL Tutorial, Introduction to Concept HDL Tutorial, product
version 15.1, Cadence® Design Systems, Inc, 2003a.

Cadence®, Using Constraint Manager in the High Speed Design Flow, Constraint
Manager User Guide, product version 15.1, Cadence® Design Systems, Inc, 2003b.

Cadence®, Concept HDL Digital Simulation tutorial, Cadence® Design Systems, Inc,
2003c.

Cadence®, Cadence® 14.2 tutorials, Cadence® Design Systems, Inc, 2003d.

Cadence®, SPECCTRAQuest™ SI Expert, Cadence® Design Systems, Inc, 2003e.

Cadence®,

SPECCTRAQuest™

Foundations,

Cadence®

SPECCTRAQuest™

Foundations course, 2004.

Coombs, C.F, Jr., Printed Circuits Handbook, Fourth Edition, McGRAW-Hill Publishing
Co., pp. 13.3, 1995.

Edwards, T., Foundations fo r Microstrip Circuit Design, Second Edition, John Wiley &
Sons, Inc., 1998.

151
Granberg, T., Digital techniques fo r High - Speed Design, Prearson Education, Inc.,
2004.

Hall, S.H., Hall, G.W. and McHall, J.A., High - Speed Digital System Design, A
handbook o f Interconnect Theory and Design Practices, John Wiley & Sons, Inc., 2000.

Lenenthal, R., Signal Integrity & EMI, presented at IPC Designers Council Designers
Learning Symposium, 2001,
http://www.winnet.com.cn/Cadence/High Speed Design/SI and EMI.pdf

Accessed:

May 2005.

Li, J., Shrivastava, P.,Gao, Z. and Zhang, H., Printed Circuit Board Recycling: A Stateof-the-Art Survey, IEEE Transactions on Printed Circuit Boards., pp. 33-41, 2004,
h ttp ://ie e e x p lo re .ie e e .O rg /ie l5 /6 104/29408/013 3 15 7 3 .p d f? a m u m b e r= l 3 3 1573

Accessed:

May 2005.

Maliniak, D., Basics of PCBs Design, Sponsored by Mentor Graphics, A Supplement to
Electronic Design, 2004,
http://www.mentor.eom/products/pcb/expedition/news/articles/upload/7162 Oil 9BasicsP
CBs.pdf Accessed: May 2005.

Mu, Z., Simulations in Guiding Gpbs PCB Design of communication systems, Ansoft
High Speed Design Forum, 2002,
http://www.ansoft.com/workshops/hsdforum/index.cfm Accessed: May 2005.

National Semiconductor, LM2653 1.5A High Efficiency Synchronous Switch Regulator,
National Semiconductor Corporation, 2005,
http:/Avww. national.com/pf7LM/LM2653.htm 1Accessed: May 2005.

152
Peter, S., Chehab, J., Lee, J., Rosenbaum, R., I/O Buffer Modeling Cookbook, Intel
Corporation, Hillsboro OR, June 02, 1994, http://www.eigroup.org/ibis/ckbookl.htm
Accessed: May 2005.

Robertson, C.T., Printed Circuit Board Designer’s Reference Basics, Prearson
Education, Inc., 2004.

Sharawi, M.S., Practical Issues in High Speed PCB design, Potentials, IEEE, Volume
Issue 2, pp. 24 - 27, 2004, http://personalwebs.oakland.edu/~msharawi/Potentials04.pdf
Accessed: May 2005.

Sivasubramaniam, S., Gorroult, P., High-Speed PCB Design: Issues, Tools, and
Methodologies, Xcell Journal, 2004,
http://www.xilinx.com/publications/xcellonline/xcell 49/xc pdf/xc overview-si49.pdf
Accessed: May 2005.

Tan, J., Calculating impedance in SPECCTRAQuest™, A SPECCTRAQuest™ FAQ,
Cadence® Design Systems, Inc., 1994.

Wikipedia contributors, “Printed Circuit Board”, wikipidia: The free encyclopedia, 2005,
http://en.wikipedia.org/wiki/Printed circuit board. Accessed: May 2005.

APPENDIX A. SCHEMATICS AND LAYOUTS

Figure A. 1 Temperature board schematic
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Figure A. 2 Temperature board layout

Figure A. 3 MSS hub power supply page 1

Figure A. 4 MSS hub power supply page 1 of 1

Figure A. 5 MSS hub power supply page 1 of 1

Figure A. 6 MSS hub power supply page 1 of 1

Figure A. 7 MSS hub power supply page 1 of 1

Figure A. 8 MSS hub power supply page 1 of 1

Figure A. 9 MSS hub power supply page 2

Figure A. 10 MSS hub power supply layout (complete)
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Figure A .ll MSS hub power supply layout (top layer)
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Figure A.12 MSS hub power supply layout (ground layer)

Figure A.13 MSS hub power supply layout (power layer)

Figure A.14 MSS hub power supply layout (bottom layer)

